vLLM: Flash late-interaction scoring caches query embeddings under a caller-controlled request id — cross-request integrity break and induced errors on /score and /rerank
CVE-2026-105755GHSA-2phq-3phc-84px
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.30.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.30.0
- Fixed in
- 0.30.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2phq-3phc-84px lists affected ranges: PyPI vllm >=0 <0.30.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2phq-3phc-84px lists affected ranges: PyPI vllm >=0 <0.30.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-105755: 0.20% estimated exploitation activity in the next 30 days; percentile 10.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected - Ecosystem / package: pip / vllm - Affected versions: vLLM ≤ 0.25.1 (confirmed on 0.25.1, commit 752a3a504485). The lower bound predates 0.25.1; maintainers can confirm how far back the flash late-interaction query cache reaches. Summary On late-interaction /score and /rerank deployments with flash late interaction enabled (the default for supported models), the worker caches per-request query embeddings under a key derived from the caller-controlled X-Request-Id header. A second concurrent request that reuses the victim's header value replaces the victim's cached query embedding before document scoring — so the victim's documents are scored against the attacker's query. Because the data-parallel router pins all requests sharing a cache key to the same engine, the collision is deterministic for an attacker who reuses the victim's X-Request-Id. Depending on timing, one request can also consume the shared use counter and force the other request into a late-interaction…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2phq-3phc-84px
- Revision 2 · amended ·
Amended from osv record GHSA-2phq-3phc-84px
- Revision 1 · created ·
Published from ghsa record GHSA-2phq-3phc-84px
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105755 Advisory: vLLM: Flash late-interaction scoring caches query embeddings under a caller-controlled request id — cross-request integrity break and induced errors on `/score` and `/rerank` IDs: CVE-2026-105755, GHSA-2phq-3phc-84px Record: https://patchnext.com/advisories/cve-2026-105755 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.30.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.30.0; fixed in 0.30.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2phq-3phc-84px (GitHub-reviewed advisory GHSA-2phq-3phc-84px lists affected ranges: PyPI vllm >=0 <0.30.0) - Verified: https://osv.dev/vulnerability/GHSA-2phq-3phc-84px (OSV record GHSA-2phq-3phc-84px lists affected ranges: PyPI vllm >=0 <0.30.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…