Docling imports plugin entry points before the allow_external_plugins check
CVE-2026-105745GHSA-9jxx-vjrv-h2rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (docling-slim 2.131.0; docling 2.131.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI docling-slim
- Affected
- >= 2.92.0, < 2.131.0
- Fixed in
- 2.131.0
PyPI docling
- Affected
- >= 2.27.0, < 2.131.0
- Fixed in
- 2.131.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jxx-vjrv-h2rq lists affected ranges: PyPI docling >=2.27.0 =2.92.0 <2.131.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9jxx-vjrv-h2rq lists affected ranges: PyPI docling >=2.27.0 =2.92.0 <2.131.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-105745: 0.12% estimated exploitation activity in the next 30 days; percentile 1.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary allowexternalplugins=False (the default, and the CLI default) is meant to restrict docling to its own model plugins. However, docling's plugin factories call pluggy's loadsetuptoolsentrypoints(), which imports every module registered under docling's plugin entry-point group. Only afterwards does docling filter out modules outside the docling. namespace. Import-time code in any installed third-party plugin therefore runs even though external plugins are disabled. Details In docling/models/factories/basefactory.py, loadfromplugins() loads all entry points first and applies the allowexternalplugins check only to the already-imported modules. The CLI creates these factories when it starts, so running docling imports every registered plugin module. A log message says the plugin "will not be loaded", although its module has already been imported. Affected configurations Environments in which a package registering a docling plugin entry point is installed, for example an unvetted or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9jxx-vjrv-h2rq
- Revision 2 · amended ·
Amended from osv record GHSA-9jxx-vjrv-h2rq
- Revision 1 · created ·
Published from ghsa record GHSA-9jxx-vjrv-h2rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105745 Advisory: Docling imports plugin entry points before the allow_external_plugins check IDs: CVE-2026-105745, GHSA-9jxx-vjrv-h2rq Record: https://patchnext.com/advisories/cve-2026-105745 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: docling-slim 2.131.0; docling 2.131.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI docling-slim: affected >= 2.92.0, < 2.131.0; fixed in 2.131.0 - PyPI docling: affected >= 2.27.0, < 2.131.0; fixed in 2.131.0 ## Suggested inspection (read-only) - `python -m pip show docling-slim`: prints the installed version. Run with the environment that serves production active. - `python -m pip show docling`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on docling-slim, docling. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9jxx-vjrv-h2rq (GitHub-reviewed advisory GHSA-9jxx-vjrv-h2rq lists affected ranges: PyPI docling >=2.27.0 =2.92.0 <2.131.0) - Verified: https://osv.dev/vulnerability/GHSA-9jxx-vjrv-h2rq (OSV record GHSA-9jxx-vjrv-h2rq lists affected ranges: PyPI docling >=2.27.0 =2.92.0 <2.131.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…