Skip to content

← Actionable
High, CVSS 7.1amended

Langflow: IP Spoofing Bypass via X-Forwarded-For Allowing Remote Configuration Write

CVE-2026-105741GHSA-4f6c-2vvp-gw82

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    >= 1.5.0, < 1.10.3
    Fixed in
    1.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-105741: 0.24% estimated exploitation activity in the next 30 days; percentile 15.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: Summary An IP spoofing vulnerability in the Model Context Protocol (MCP) configuration installation endpoint (POST /api/v1/mcp/project/{projectid}/install) allowed authenticated remote attackers to bypass the "local-only" access restriction. By sending a spoofed X-Forwarded-For: 127.0.0.1 header, an attacker could make the server treat the request as originating from localhost, letting them write/overwrite an MCP client configuration file on the server's filesystem. Details The vulnerability lived in the getclientip helper, used to enforce the local-only gate for installmcpconfig. It trusted the leftmost (fully client-controlled) entry of X-Forwarded-For unconditionally, with no check for whether the request had actually passed through a trusted proxy. Vulnerable code (introduced by commit d3d06be8e5, first released in v1.5.0): src/backend/base/langflow/api/v1/mcpprojects.py Correction vs. the original report: the request body accepted by this endpoint is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4f6c-2vvp-gw82

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4f6c-2vvp-gw82

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4f6c-2vvp-gw82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105741

Advisory: Langflow: IP Spoofing Bypass via `X-Forwarded-For` Allowing Remote Configuration Write
IDs: CVE-2026-105741, GHSA-4f6c-2vvp-gw82
Record: https://patchnext.com/advisories/cve-2026-105741 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected >= 1.5.0, < 1.10.3; fixed in 1.10.3

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4f6c-2vvp-gw82 (GitHub-reviewed advisory GHSA-4f6c-2vvp-gw82 lists affected ranges: PyPI langflow >=1.5.0 <1.10.3)
- Verified: https://osv.dev/vulnerability/GHSA-4f6c-2vvp-gw82 (OSV record GHSA-4f6c-2vvp-gw82 lists affected ranges: PyPI langflow >=1.5.0 <1.10.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…