Skip to content

← Actionable
High, CVSS 7.1amended

Langflow has Authenticated Cross-Project File Disclosure via Unscoped MCP Resource Handlers

CVE-2026-105699GHSA-4hmc-cfm3-w43c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    >= 1.6.8, <= 1.9.0
    Fixed in
    1.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-105699: 0.31% estimated exploitation activity in the next 30 days; percentile 24.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Langflow's project-scoped MCP transport authenticates the caller for the projectid in the connection URL, but the subsequent resources/read operation does not authorize the resource URI being requested. An authenticated user can connect to their own project-scoped MCP endpoint and supply a crafted file-download URI that points to another user's flow-backed file. The server then reads and returns the victim file without verifying ownership or project membership. This is a cross-user authorization bypass (userA - userB) that allows arbitrary read access to files stored under other users' flow namespaces. Details Verified against local checkout: - Repository: langflow-ai/langflow - Verified on release tag: v1.8.3 - Commit: 08bf98404cfd7737fde57a2588785766cdf1b42e - Earliest stable release known to contain the vulnerable code path: v1.6.8 Relevant code path: 1. src/backend/base/langflow/api/v1/mcpprojects.py:147-193 verifyprojectauthconditional() authenticates the caller and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4hmc-cfm3-w43c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4hmc-cfm3-w43c

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4hmc-cfm3-w43c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105699

Advisory: Langflow has Authenticated Cross-Project File Disclosure via Unscoped MCP Resource Handlers
IDs: CVE-2026-105699, GHSA-4hmc-cfm3-w43c
Record: https://patchnext.com/advisories/cve-2026-105699 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected >= 1.6.8, <= 1.9.0; fixed in 1.9.1

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4hmc-cfm3-w43c (GitHub-reviewed advisory GHSA-4hmc-cfm3-w43c lists affected ranges: PyPI langflow >=1.6.8 <=1.9.0)
- Verified: https://osv.dev/vulnerability/GHSA-4hmc-cfm3-w43c (OSV record GHSA-4hmc-cfm3-w43c lists affected ranges: PyPI langflow >=1.6.8 <1.9.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…