Skip to content

← Actionable
Medium, CVSS 5.4amended

Langflow : Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints

CVE-2026-105698GHSA-gh98-4phw-6fmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow-base 0.10.1; langflow 1.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-105698: 0.22% estimated exploitation activity in the next 30 days; percentile 13.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Before Langflow 1.10.1, two deprecated but still-routed endpoints in the chat API did not check that the authenticated caller owns the flow referenced in the URL path: - POST /api/v1/build/{flowid}/vertices (retrieveverticesorder) - POST /api/v1/build/{flowid}/vertices/{vertexid} (buildvertex) Any authenticated user who knows (or obtains) another user's flowid could load that user's private flow graph, enumerate its vertex IDs, and build (execute) individual vertices of it, receiving the vertex results in the response. Both routes are declared with deprecated=True, includeinschema=False, so they do not appear in the OpenAPI docs, but they remained registered on the router. The Langflow UI no longer calls them (it uses POST /api/v1/build/{flowid}/flow), so they are only reachable by direct HTTP requests. The issue is fixed in Langflow 1.10.1 (langflow-base 0.10.1) by #13153. Details In affected versions, both handlers go straight to the graph loader: - retrieveverticesorder…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gh98-4phw-6fmw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gh98-4phw-6fmw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gh98-4phw-6fmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105698

Advisory: Langflow : Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints
IDs: CVE-2026-105698, GHSA-gh98-4phw-6fmw
Record: https://patchnext.com/advisories/cve-2026-105698 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow-base 0.10.1; langflow 1.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow-base: affected < 0.10.1; fixed in 0.10.1
- PyPI langflow: affected >= 1.0.0, < 1.10.1; fixed in 1.10.1

## Suggested inspection (read-only)
- `python -m pip show langflow-base`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow-base, langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gh98-4phw-6fmw (GitHub-reviewed advisory GHSA-gh98-4phw-6fmw lists affected ranges: PyPI langflow >=1.0.0 =0 <0.10.1)
- Verified: https://osv.dev/vulnerability/GHSA-gh98-4phw-6fmw (OSV record GHSA-gh98-4phw-6fmw lists affected ranges: PyPI langflow >=1.0.0 =0 <0.10.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…