Skip to content

← Actionable
Medium, CVSS 5.1amended

Ghost: Server-Side Request Forgery in Webhook Trigger

CVE-2026-105682GHSA-354h-gmhv-mr9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 1.18.0, < 6.27.0
    Fixed in
    6.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-103287: 0.20% estimated exploitation activity in the next 30 days; percentile 10.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-105682: 0.24% estimated exploitation activity in the next 30 days; percentile 15.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An SSRF vulnerability in the webhooks feature allowed staff users to probe internal hosts from the Ghost server. Vulnerable versions This vulnerability is present in Ghost from v1.18.0 up to v6.27.0. Patches v6.27.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks 0xkakash1, rooks00, l3tchupkt, Wernerina, krn0@bugcrowdninja.com, and Mohamed Bassia for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-354h-gmhv-mr9c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-354h-gmhv-mr9c

  4. Revision 1 · created ·

    Published from ghsa record GHSA-354h-gmhv-mr9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105682

Advisory: Ghost: Server-Side Request Forgery in Webhook Trigger
IDs: CVE-2026-105682, GHSA-354h-gmhv-mr9c
Record: https://patchnext.com/advisories/cve-2026-105682 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 1.18.0, < 6.27.0; fixed in 6.27.0

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-354h-gmhv-mr9c (GitHub-reviewed advisory GHSA-354h-gmhv-mr9c lists affected ranges: npm ghost >=1.18.0 <6.27.0)
- Verified: https://osv.dev/vulnerability/GHSA-354h-gmhv-mr9c (OSV record GHSA-354h-gmhv-mr9c lists affected ranges: npm ghost >=1.18.0 <6.27.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…