Ghost: Authorization Issue Allowed Author Role to Delete any Post
CVE-2026-105680GHSA-x3mg-q38v-m562
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.60.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 5.81.0, < 6.60.0
- Fixed in
- 6.60.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x3mg-q38v-m562 lists affected ranges: npm ghost >=5.81.0 <6.60.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x3mg-q38v-m562 lists affected ranges: npm ghost >=5.81.0 <6.60.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-105680: 0.27% estimated exploitation activity in the next 30 days; percentile 19.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Staff with the Author role could delete posts and pages that they did not author. Vulnerable versions This vulnerability is present in Ghost from v5.81.0 up to v6.60.0. Patches v6.60.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks Ethan Wilkins of Armadin, Mihir Shishulkar, Jan Kahmen of TuringPoint, and Hao Long for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at security@ghost.org.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x3mg-q38v-m562
- Revision 2 · amended ·
Amended from osv record GHSA-x3mg-q38v-m562
- Revision 1 · created ·
Published from ghsa record GHSA-x3mg-q38v-m562
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105680 Advisory: Ghost: Authorization Issue Allowed Author Role to Delete any Post IDs: CVE-2026-105680, GHSA-x3mg-q38v-m562 Record: https://patchnext.com/advisories/cve-2026-105680 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 6.60.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 5.81.0, < 6.60.0; fixed in 6.60.0 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x3mg-q38v-m562 (GitHub-reviewed advisory GHSA-x3mg-q38v-m562 lists affected ranges: npm ghost >=5.81.0 <6.60.0) - Verified: https://osv.dev/vulnerability/GHSA-x3mg-q38v-m562 (OSV record GHSA-x3mg-q38v-m562 lists affected ranges: npm ghost >=5.81.0 <6.60.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…