Skip to content

← Actionable
High, CVSS 8.6amended

Ghost: Stored XSS via oEmbed Photo Responses

CVE-2026-105650GHSA-v3xr-g6p2-fvgv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.64.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 2.5.0, < 6.64.0
    Fixed in
    6.64.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-104414: 0.28% estimated exploitation activity in the next 30 days; percentile 20.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-105650: 0.33% estimated exploitation activity in the next 30 days; percentile 25.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session. Vulnerable versions This vulnerability is present in Ghost from v2.1.0 up to v6.64.0. Patches v6.64.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks SecBuddyF of Tencent KeenLab and Nhat Anh Vu for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-v3xr-g6p2-fvgv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-v3xr-g6p2-fvgv

  4. Revision 1 · created ·

    Published from ghsa record GHSA-v3xr-g6p2-fvgv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105650

Advisory: Ghost: Stored XSS via oEmbed Photo Responses
IDs: CVE-2026-105650, GHSA-v3xr-g6p2-fvgv
Record: https://patchnext.com/advisories/cve-2026-105650 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.64.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 2.5.0, < 6.64.0; fixed in 6.64.0

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v3xr-g6p2-fvgv (GitHub-reviewed advisory GHSA-v3xr-g6p2-fvgv lists affected ranges: npm ghost >=2.5.0 <6.64.0)
- Verified: https://osv.dev/vulnerability/GHSA-v3xr-g6p2-fvgv (OSV record GHSA-v3xr-g6p2-fvgv lists affected ranges: npm ghost >=2.5.0 <6.64.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…