Skip to content

← Actionable
Medium, CVSS 6.8amended

Ghost : Stored XSS via SVG Files in Content Imports

CVE-2026-105644GHSA-hqq2-xqr2-fmx2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.67.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 4.0.0, < 6.67.0
    Fixed in
    6.67.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-105644: 0.32% estimated exploitation activity in the next 30 days; percentile 25.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact SVG images included in content imports were stored without sanitization. An attacker who convinced an Administrator to import a crafted file could host scripts on the site's domain, possibly resulting in compromise of staff users' admin sessions. Vulnerable versions This vulnerability is present in Ghost from v4.0.0 up to v6.65.0. Patches v6.67.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks Zhixi "Jace" Sun, independent security researcher, for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hqq2-xqr2-fmx2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hqq2-xqr2-fmx2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hqq2-xqr2-fmx2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105644

Advisory: Ghost : Stored XSS via SVG Files in Content Imports
IDs: CVE-2026-105644, GHSA-hqq2-xqr2-fmx2
Record: https://patchnext.com/advisories/cve-2026-105644 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.67.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 4.0.0, < 6.67.0; fixed in 6.67.0

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hqq2-xqr2-fmx2 (GitHub-reviewed advisory GHSA-hqq2-xqr2-fmx2 lists affected ranges: npm ghost >=4.0.0 <6.67.0)
- Verified: https://osv.dev/vulnerability/GHSA-hqq2-xqr2-fmx2 (OSV record GHSA-hqq2-xqr2-fmx2 lists affected ranges: npm ghost >=4.0.0 <6.67.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…