Langflow: PythonREPLComponent executes unsandboxed Python code, enabling authenticated RCE and privilege escalation
CVE-2026-10561GHSA-8qpj-27x8-pwpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- < 1.10.1
- Fixed in
- 1.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qpj-27x8-pwpq lists affected ranges: PyPI langflow >=0 <1.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8qpj-27x8-pwpq lists affected ranges: PyPI langflow >=0 <1.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-10561: 0.82% estimated exploitation activity in the next 30 days; percentile 57.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Langflow's built-in Python interpreter components — PythonREPLComponent (Python Interpreter) and the legacy PythonREPLToolComponent (Python REPL Tool) — executed arbitrary user- or model-supplied Python code inside flows without effective sandboxing. Because the code ran in-process with the privileges of the Langflow service, any authenticated user who could edit and run a flow could achieve remote code execution and, from there, escalate privileges to superuser (e.g. by opening a database session and flipping issuperuser) or compromise the host. This issue is fixed as of 1.10.1, with additional hardening through 1.12.3. See Remediation below. Affected - Package: langflow (PyPI), and the underlying lfx package that ships the component. - Vulnerable versions: < 1.10.1. - Patched: 1.10.1 (core fix). Upgrade to = 1.12.3 for the complete hardening series. Details The root cause is code injection (CWE-94/CWE-95): the component passed raw input to LangChain's PythonREPL, which is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8qpj-27x8-pwpq
- Revision 2 · amended ·
Amended from osv record GHSA-8qpj-27x8-pwpq
- Revision 1 · created ·
Published from ghsa record GHSA-8qpj-27x8-pwpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-10561 Advisory: Langflow: PythonREPLComponent executes unsandboxed Python code, enabling authenticated RCE and privilege escalation IDs: CVE-2026-10561, GHSA-8qpj-27x8-pwpq Record: https://patchnext.com/advisories/cve-2026-10561 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected < 1.10.1; fixed in 1.10.1 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8qpj-27x8-pwpq (GitHub-reviewed advisory GHSA-8qpj-27x8-pwpq lists affected ranges: PyPI langflow >=0 <1.10.1) - Verified: https://osv.dev/vulnerability/GHSA-8qpj-27x8-pwpq (OSV record GHSA-8qpj-27x8-pwpq lists affected ranges: PyPI langflow >=0 <1.10.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…