TLS certificate hostname bypass when the IP is written fullwidth digits
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-min 26.12.1, 24.22.1; node 26.12.1, 24.22.1; node 26.12.1, 24.22.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami node-min
- Affected
- >= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
- Fixed in
- 26.12.1, 24.22.1
runtime node
- Affected
- >= 24.0.0, < 24.22.1>= 26.0.0, < 26.12.1
- Fixed in
- 26.12.1, 24.22.1
Bitnami node
- Affected
- >= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
- Fixed in
- 26.12.1, 24.22.1
Sources
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 197 lists CVE-2026-105483 affecting node >=24.0.0 =26.0.0 <26.12.1
VerifiedObserved Authoritative source for Node.js core CVEs: structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2026-105483 to 2026-10-20.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-node-2026-105483 lists affected ranges: Bitnami node >=23.0.0 =25.0.0 <26.12.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-node-min-2026-105483 lists affected ranges: Bitnami node-min >=23.0.0 =25.0.0 <26.12.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-105483: 0.30% estimated exploitation activity in the next 30 days; percentile 23.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw in Node.js TLS hostname verification allows a certificate without a matching IP address SAN to authenticate a connection to an IPv4 address when the host is written with non-ASCII characters, such as fullwidth digits (`127.0.0.1`). `tls.checkServerIdentity()` did not recognize such hosts as IP addresses, even though they normalize and resolve to a regular IPv4 address, and matched them against the certificate DNS names and Common Name instead. A certificate containing `DNS:127.0.0.1` or `DNS:*.0.0.1` could therefore be accepted for an IP endpoint it was not issued for. This is a regression introduced after the fix for CVE-2026-48618. This vulnerability affects Node.js 26.x and 24.x.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-node-min-2026-105483
- Revision 2 · amended ·
Amended from osv record BIT-node-2026-105483
- Revision 1 · created ·
Published from vendor_advisory record nodejs-security-wg:core:197
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105483 Advisory: TLS certificate hostname bypass when the IP is written fullwidth digits IDs: CVE-2026-105483 Record: https://patchnext.com/advisories/cve-2026-105483 (revision 3, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-min 26.12.1, 24.22.1; node 26.12.1, 24.22.1; node 26.12.1, 24.22.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami node-min: affected >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 24.22.1 - runtime node: affected >= 24.0.0, < 24.22.1; >= 26.0.0, < 26.12.1; fixed in 26.12.1, 24.22.1 - Bitnami node: affected >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 24.22.1 ## Suggested inspection (read-only) - Bitnami node-min: check the installed version with your package manager. - runtime node: check the installed version with your package manager. - Bitnami node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-min, node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/197.json (Node.js security working group core entry 197 lists CVE-2026-105483 affecting node >=24.0.0 =26.0.0 <26.12.1) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-105483 to 2026-10-20.) - Verified: https://osv.dev/vulnerability/BIT-node-2026-105483 (OSV record BIT-node-2026-105483 lists affected ranges: Bitnami node >=23.0.0 =25.0.0 <26.12.1 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-node-min-2026-105483 (OSV record BIT-node-min-2026-105483 lists affected ranges: Bitnami node-min >=23.0.0 =25.0.0 <26.12.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…