Crossplane's TOCTOU between cosign verification and image fetch in xpkg.CachedClient allows tag-based package install to bypass signature check
CVE-2026-105163GHSA-mf7q-r4rv-jv94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/crossplane/crossplane-runtime/v2 2.4.0-rc.1, 2.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/crossplane/crossplane-runtime/v2
- Affected
- >= 2.4.0-rc.0, <= 2.4.0-rc.0>= 2.3.0, <= 2.3.2
- Fixed in
- 2.3.3, 2.4.0-rc.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mf7q-r4rv-jv94 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.4.0-rc.0 =2.3.0 <2.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6302 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.3.0 =2.4.0-rc.0 <2.4.0-rc.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mf7q-r4rv-jv94 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.4.0-rc.0 =2.3.0 <=2.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-105163: 0.32% estimated exploitation activity in the next 30 days; percentile 25.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Crossplane allows package signature verification to be configured via the ImageConfig mechanism. When enabled, the package manager uses cosign to verify that packages are correctly signed before pulling and installing them. When a package is installed using a tag reference (e.g., a semantic version), a malicious OCI registry could serve a correctly signed image for verification, then subsequently serve an unsigned image for installation. This is possible because Crossplane resolves the tag reference separately for each step. This vulnerability is relevant only for users who do all three of the following: 1. Configure signature verification for packages, 2. Install packages using tag references rather than digests, and 3. Install packages from registries they do not control. Mitigation Installing packages by image digest rather than using tags avoids this issue. Fix The package manager has been updated to resolve tag references once and use the resulting digest for both…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-mf7q-r4rv-jv94
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6302
- Revision 1 · created ·
Published from osv record GHSA-mf7q-r4rv-jv94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105163 Advisory: Crossplane's TOCTOU between cosign verification and image fetch in xpkg.CachedClient allows tag-based package install to bypass signature check IDs: CVE-2026-105163, GHSA-mf7q-r4rv-jv94 Record: https://patchnext.com/advisories/cve-2026-105163 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/crossplane/crossplane-runtime/v2 2.4.0-rc.1, 2.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/crossplane/crossplane-runtime/v2: affected >= 2.4.0-rc.0, <= 2.4.0-rc.0; >= 2.3.0, <= 2.3.2; fixed in 2.3.3, 2.4.0-rc.1 ## Suggested inspection (read-only) - Go github.com/crossplane/crossplane-runtime/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/crossplane/crossplane-runtime/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mf7q-r4rv-jv94 (OSV record GHSA-mf7q-r4rv-jv94 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.4.0-rc.0 =2.3.0 <2.3.3 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6302 (OSV record GO-2026-6302 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.3.0 =2.4.0-rc.0 <2.4.0-rc.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mf7q-r4rv-jv94 (GitHub-reviewed advisory GHSA-mf7q-r4rv-jv94 lists affected ranges: Go github.com/crossplane/crossplane-runtime/v2 >=2.4.0-rc.0 =2.3.0 <=2.3.2) Commands are suggestions: review each one before running it.
Loading voting…