Skip to content

← Actionable
High, CVSS 7.2amended

Kunstmaan CMS: MediaBundle extension blacklist bypass allows authenticated administrators to upload executable PHP files leading to remote code execution

CVE-2026-104890GHSA-p279-5wcv-45vq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kunstmaan/bundles-cms 7.3.2; kunstmaan/media-bundle 7.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-104890: 0.42% estimated exploitation activity in the next 30 days; percentile 35.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The MediaBundle blocks dangerous upload extensions with a blacklist that was matched case-sensitively, while the stored filename was lowercased afterwards. A file uploaded as webshell.pHp therefore bypassed the blacklist and was written to the web-accessible upload directory as webshell.php, where the web server executed it. Any authenticated backend user with access to the media section could obtain remote code execution. Details FileHandler::getFilePath() rewrote blacklisted extensions to .txt using a case-sensitive regex, and only then lowercased the extension when building the stored name — so the check ran against the attacker-controlled casing and the normalisation happened after it. Two further weaknesses contributed: The default blacklist contained only php and htaccess, leaving other server-executable extensions (phtml, php5, phar, shtml, cgi, …) unblocked regardless of casing. Configured blacklist values were interpolated into the regex unescaped. Impact An…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p279-5wcv-45vq

  2. Revision 1 · created ·

    Published from osv record GHSA-p279-5wcv-45vq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-104890

Advisory: Kunstmaan CMS: MediaBundle extension blacklist bypass allows authenticated administrators to upload executable PHP files leading to remote code execution
IDs: CVE-2026-104890, GHSA-p279-5wcv-45vq
Record: https://patchnext.com/advisories/cve-2026-104890 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kunstmaan/bundles-cms 7.3.2; kunstmaan/media-bundle 7.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kunstmaan/bundles-cms: affected < 7.3.2; fixed in 7.3.2
- Packagist kunstmaan/media-bundle: affected < 7.3.2; fixed in 7.3.2

## Suggested inspection (read-only)
- Packagist kunstmaan/bundles-cms: check the installed version with your package manager.
- Packagist kunstmaan/media-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kunstmaan/bundles-cms, kunstmaan/media-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p279-5wcv-45vq (OSV record GHSA-p279-5wcv-45vq lists affected ranges: Packagist kunstmaan/media-bundle >=0 =0 <7.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p279-5wcv-45vq (GitHub-reviewed advisory GHSA-p279-5wcv-45vq lists affected ranges: Packagist kunstmaan/media-bundle >=0 =0 <7.3.2)

Commands are suggestions: review each one before running it.

Loading voting…