Skip to content

← Actionable
High, CVSS 7.6amended

LangGraph SDK custom auth silently ignores actions= on resource decorators

CVE-2026-104873GHSA-fvww-7h3r-vfhp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-sdk 0.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-104873: 0.25% estimated exploitation activity in the next 30 days; percentile 16.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? langgraph-sdk incorrectly applies the actions= argument on resource-scoped authorization decorators, including @auth.on.threads, @auth.on.assistants, and @auth.on.crons. In affected versions, a decorator such as: intended to register a handler for selected actions instead registers that handler for every action on the resource. Because the resource-wide handler is selected before broader fallback handlers, authorization checks implemented in those fallback handlers may not run. An authenticated user may therefore be able to perform actions the application intended to deny, such as reading, updating, or deleting another user's resource. Exploitability and impact depend on the affected handler's behavior: deployments remain protected if that handler independently enforces the necessary action, ownership, or permission checks for every request it receives. Only Python deployments using actions= on the affected resource-scoped…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-fvww-7h3r-vfhp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-fvww-7h3r-vfhp

  4. Revision 1 · created ·

    Published from ghsa record GHSA-fvww-7h3r-vfhp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-104873

Advisory: LangGraph SDK custom auth silently ignores actions= on resource decorators
IDs: CVE-2026-104873, GHSA-fvww-7h3r-vfhp
Record: https://patchnext.com/advisories/cve-2026-104873 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-sdk 0.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-sdk: affected >= 0.1.45, <= 0.4.3; fixed in 0.4.4

## Suggested inspection (read-only)
- `python -m pip show langgraph-sdk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fvww-7h3r-vfhp (GitHub-reviewed advisory GHSA-fvww-7h3r-vfhp lists affected ranges: PyPI langgraph-sdk >=0.1.45 <=0.4.3)
- Verified: https://osv.dev/vulnerability/GHSA-fvww-7h3r-vfhp (OSV record GHSA-fvww-7h3r-vfhp lists affected ranges: PyPI langgraph-sdk >=0.1.45 <0.4.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…