Skip to content

← Actionable
High, CVSS 7.3amended

@nx/docker: OS command injection in the @nx/docker release pipeline

CVE-2026-104859GHSA-6vc5-vf29-ffr2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nx/docker 23.1.1, 22.7.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @nx/docker

    Affected
    >= 21.4.0, < 22.7.8>= 23.0.0, < 23.1.1
    Fixed in
    23.1.1, 22.7.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-104859: 0.15% estimated exploitation activity in the next 30 days; percentile 4.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The @nx/docker release pipeline builds its docker invocations as shell command strings, interpolating release.docker.repositoryName and registryUrl from Nx configuration into them. Because those strings are handed to /bin/sh -c, a crafted repository or registry name executes as a command during nx release version and nx release publish. Anyone running a Docker release against a repository whose Nx configuration they do not control — or whose configuration a pull request has changed — executes the injected command with the privileges of the release job, which in CI typically holds registry credentials and cloud tokens. Severity Exploitable when someone runs a Docker release against attacker-supplied configuration, with high impact because release jobs hold publishing credentials. There is no known evidence of exploitation in the wild. Affected & Patched Versions | Package | Vulnerable | Patched | | --- | --- | --- | | @nx/docker | = 21.4.0, < 22.7.8; = 23.0.0, < 23.1.1 |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-6vc5-vf29-ffr2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-6vc5-vf29-ffr2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-6vc5-vf29-ffr2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-104859

Advisory: @nx/docker: OS command injection in the @nx/docker release pipeline
IDs: CVE-2026-104859, GHSA-6vc5-vf29-ffr2
Record: https://patchnext.com/advisories/cve-2026-104859 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nx/docker 23.1.1, 22.7.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nx/docker: affected >= 21.4.0, < 22.7.8; >= 23.0.0, < 23.1.1; fixed in 23.1.1, 22.7.8

## Suggested inspection (read-only)
- `npm ls @nx/docker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nx/docker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6vc5-vf29-ffr2 (GitHub-reviewed advisory GHSA-6vc5-vf29-ffr2 lists affected ranges: npm @nx/docker >=21.4.0 =23.0.0 <23.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-6vc5-vf29-ffr2 (OSV record GHSA-6vc5-vf29-ffr2 lists affected ranges: npm @nx/docker >=21.4.0 =23.0.0 <23.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…