Skip to content

← Actionable
High, CVSS 8.5amended

Nx daemon and plugin worker sockets are accessible to other local users

CVE-2026-104854GHSA-w3vv-58gj-gw77

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nx 23.1.2, 22.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nx

    Affected
    >= 14.6.0, < 22.7.9>= 23.0.0, < 23.1.2
    Fixed in
    22.7.9, 23.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-104854: 0.14% estimated exploitation activity in the next 30 days; percentile 3.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Nx creates the Unix domain sockets for its daemon and its plugin workers in a shared temporary directory with default permissions, so any other user on the same machine can connect to them. The daemon accepts a PROCESSINBACKGROUND request that names a module to load and invokes its default export, which turns socket access into code execution inside the daemon process. On a multi-user machine — a shared build server, a shared developer box, or a container running several accounts — one local user can execute code as another user running Nx. Severity Exploitable by any other unprivileged local user on a shared host while a daemon or plugin worker is running, with no user interaction. There is no known evidence of exploitation in the wild. Affected & Patched Versions | Package | Vulnerable | Patched | | --- | --- | --- | | nx | = 14.6.0, < 22.7.9; = 23.0.0, < 23.1.2 | 22.7.9, 23.1.2 | Every version in the ranges above is affected. The lower bound is 14.6.0, when the daemon…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-w3vv-58gj-gw77

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-w3vv-58gj-gw77

  4. Revision 1 · created ·

    Published from ghsa record GHSA-w3vv-58gj-gw77

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-104854

Advisory: Nx daemon and plugin worker sockets are accessible to other local users
IDs: CVE-2026-104854, GHSA-w3vv-58gj-gw77
Record: https://patchnext.com/advisories/cve-2026-104854 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nx 23.1.2, 22.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nx: affected >= 14.6.0, < 22.7.9; >= 23.0.0, < 23.1.2; fixed in 22.7.9, 23.1.2

## Suggested inspection (read-only)
- `npm ls nx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3vv-58gj-gw77 (GitHub-reviewed advisory GHSA-w3vv-58gj-gw77 lists affected ranges: npm nx >=14.6.0 =23.0.0 <23.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-w3vv-58gj-gw77 (OSV record GHSA-w3vv-58gj-gw77 lists affected ranges: npm nx >=14.6.0 =23.0.0 <23.1.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…