fsspec: Server-Side Template Injection in ReferenceFileSystem leads to Remote Code Execution
CVE-2026-104851GHSA-27vj-qcqg-25rc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fsspec 2026.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fsspec
- Affected
- >= 0.9.0, < 2026.6.0
- Fixed in
- 2026.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27vj-qcqg-25rc lists affected ranges: PyPI fsspec >=0.9.0 <2026.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27vj-qcqg-25rc lists affected ranges: PyPI fsspec >=0.9.0 <2026.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-104851: 0.47% estimated exploitation activity in the next 30 days; percentile 41.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary fsspec.implementations.reference.ReferenceFileSystem parses a "references" JSON document (Kerchunk format) supplied either inline or via a URL. The parser renders fields from this JSON through un-sandboxed jinja2.Template(...).render(...) calls in three locations. An attacker who controls the JSON document — typically by hosting it at a URL that the victim opens with fsspec.filesystem("reference", fo=URL) or via xarray.opendataset("reference://...") — achieves arbitrary Python code execution on the victim machine, before any data is read. This mirrors the pattern of CVE-2024-34359 in llama-cpp-python, where externally-sourced template strings were rendered with the default unrestricted Jinja2 environment. Affected versions All versions of fsspec from 0.9.0 onward (vulnerable code introduced in commit 0fb8d56b684ee74ad9ad4587fd560bde1b116450, 2021-03-12). Confirmed on the latest released version 2025.10.0. Affected sinks All in fsspec/implementations/reference.py: | Sink |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-27vj-qcqg-25rc
- Revision 2 · amended ·
Amended from osv record GHSA-27vj-qcqg-25rc
- Revision 1 · created ·
Published from ghsa record GHSA-27vj-qcqg-25rc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-104851 Advisory: fsspec: Server-Side Template Injection in ReferenceFileSystem leads to Remote Code Execution IDs: CVE-2026-104851, GHSA-27vj-qcqg-25rc Record: https://patchnext.com/advisories/cve-2026-104851 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fsspec 2026.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fsspec: affected >= 0.9.0, < 2026.6.0; fixed in 2026.6.0 ## Suggested inspection (read-only) - `python -m pip show fsspec`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fsspec. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27vj-qcqg-25rc (GitHub-reviewed advisory GHSA-27vj-qcqg-25rc lists affected ranges: PyPI fsspec >=0.9.0 <2026.6.0) - Verified: https://osv.dev/vulnerability/GHSA-27vj-qcqg-25rc (OSV record GHSA-27vj-qcqg-25rc lists affected ranges: PyPI fsspec >=0.9.0 <2026.6.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…