Skip to content

← Actionable
Medium, CVSS 5.3amended

copyparty FTP: upload outside defined volumes (limited path traversal)

CVE-2026-104102GHSA-phv8-wgjp-g4p9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (copyparty 1.20.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI copyparty

    Affected
    < 1.20.19
    Fixed in
    1.20.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-104102: 0.31% estimated exploitation activity in the next 30 days; percentile 24.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The FTP and FTPS server -- if enabled -- would allow uploading to any folder that the copyparty process had permission to write to. The FTP-server is default-disabled, and must be explicitly enabled in the config with global-option ftp or ftps to be affected. Additionally, SFTP was not affected at all; only FTP and FTPS. This was not a full read/write path-traversal; it had the following limitations: Only applied to uploads; it was not possible to read/download existing files in this manner. The output filename was not fully controllable; a randomized suffix would always be appended to the filename. Existing files could not be overwritten or appended to; only new files could be created. Filesystem-permissions would prevent writing to system folders, as copyparty surely does not run as root in most deployments. Copyparty itself will not execute arbitrary files as code by default, so this vulnerability could not be used to execute arbitrary code through copyparty. The main concern is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-phv8-wgjp-g4p9

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-phv8-wgjp-g4p9

  4. Revision 1 · created ·

    Published from ghsa record GHSA-phv8-wgjp-g4p9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-104102

Advisory: copyparty FTP: upload outside defined volumes (limited path traversal)
IDs: CVE-2026-104102, GHSA-phv8-wgjp-g4p9
Record: https://patchnext.com/advisories/cve-2026-104102 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: copyparty 1.20.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI copyparty: affected < 1.20.19; fixed in 1.20.19

## Suggested inspection (read-only)
- `python -m pip show copyparty`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on copyparty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-phv8-wgjp-g4p9 (GitHub-reviewed advisory GHSA-phv8-wgjp-g4p9 lists affected ranges: PyPI copyparty >=0 <1.20.19)
- Verified: https://osv.dev/vulnerability/GHSA-phv8-wgjp-g4p9 (OSV record GHSA-phv8-wgjp-g4p9 lists affected ranges: PyPI copyparty >=0 <1.20.19 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…