Skip to content

← Actionable
Medium, CVSS 6.5amended

Appium: Symlink based Zip Slip in @appium/support ZIP extraction

CVE-2026-103975GHSA-qfxx-c367-67f8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@appium/support 7.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-103975: 0.64% estimated exploitation activity in the next 30 days; percentile 50.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CVE-2026-30973 (GHSA-rfx7-4xw3-gh4m) was a plain path traversal in the entry name. The containment check built an Error object without throwing it, so an entry literally named something like ../evil.txt was written outside the destination. That issue was fixed in @appium/support 7.0.6 by actually rejecting out of bound entry names. This finding is a different vector that the 7.0.6 fix does not cover. The archive entry names here are completely legitimate (for example pwn and pwn/owned.txt, no .. anywhere), so every name based defense accepts them. The escape happens through a symbolic link. One entry is a symlink whose target points outside the extraction directory, and a later entry is a regular file whose name resolves through that symlink. The name based containment check never inspects the symlink target, and the extractor writes the symlink target verbatim, so the file lands outside the extraction root. The two issues compared on the same patched version 7.2.5: | |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qfxx-c367-67f8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qfxx-c367-67f8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qfxx-c367-67f8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-103975

Advisory: Appium: Symlink based Zip Slip in @appium/support ZIP extraction
IDs: CVE-2026-103975, GHSA-qfxx-c367-67f8
Record: https://patchnext.com/advisories/cve-2026-103975 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @appium/support 7.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @appium/support: affected <= 7.2.5; fixed in 7.2.6

## Suggested inspection (read-only)
- `npm ls @appium/support --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @appium/support.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qfxx-c367-67f8 (GitHub-reviewed advisory GHSA-qfxx-c367-67f8 lists affected ranges: npm @appium/support >=0 <=7.2.5)
- Verified: https://osv.dev/vulnerability/GHSA-qfxx-c367-67f8 (OSV record GHSA-qfxx-c367-67f8 lists affected ranges: npm @appium/support >=0 <7.2.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…