Skip to content

← Actionable
High, CVSS 7.8amended

mise permits untrusted local configuration to override default shell arguments

CVE-2026-103929GHSA-g74g-rg72-j2p3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mise 2026.7.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io mise

    Affected
    <= 2026.7.13
    Fixed in
    2026.7.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-103929: 0.26% estimated exploitation activity in the next 30 days; percentile 17.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Untrusted local .mise.toml [settings] can set the shell interpreter args (unix/windows defaultinline / defaultfile shellargs), yielding arbitrary command execution, because those command-interpreter settings were not added to the globalonly denylist the CVE-2026-55448 fix relies on. Code execution from an untrusted repository with no trust prompt for the malicious file, on par with the patched CVE. Confirmed at HEAD 7160170206782fdd3ef287c8302369e32152fb71. The defect CVE-2026-55448 and CVE-2026-35533 fixed the fact that a local project [settings] table is harvested by the settings preloader independent of the trust store (an untrusted .mise.toml sets settings without the user ever trusting it). The remediation is a per-field globalonly denylist: settings marked globalonly are stripped from non-global config. The maintainers marked the command-execution fields they knew about (the three forge credentialcommand values) but did not mark the four shell-interpreter-args settings,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g74g-rg72-j2p3

  2. Revision 1 · created ·

    Published from osv record GHSA-g74g-rg72-j2p3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-103929

Advisory: mise permits untrusted local configuration to override default shell arguments
IDs: CVE-2026-103929, GHSA-g74g-rg72-j2p3
Record: https://patchnext.com/advisories/cve-2026-103929 (revision 2, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mise 2026.7.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io mise: affected <= 2026.7.13; fixed in 2026.7.14

## Suggested inspection (read-only)
- crates.io mise: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g74g-rg72-j2p3 (OSV record GHSA-g74g-rg72-j2p3 lists affected ranges: crates.io mise >=0 <2026.7.14 (fixed))
- Verified: https://github.com/advisories/GHSA-g74g-rg72-j2p3 (GitHub-reviewed advisory GHSA-g74g-rg72-j2p3 lists affected ranges: crates.io mise >=0 <=2026.7.13)

Commands are suggestions: review each one before running it.

Loading voting…