Skip to content

← Actionable
Low, CVSS 2.1amended

KaTeX: Existing prototype pollution can bypass trust restrictions

CVE-2026-103923GHSA-238p-pmpm-9mq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (katex 0.18.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm katex

    Affected
    >= 0.11.0, < 0.18.2
    Fixed in
    0.18.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-103923: 0.30% estimated exploitation activity in the next 30 days; percentile 22.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact KaTeX can act as a read-side prototype pollution gadget in applications where Object.prototype has already been polluted, or where an attacker can influence the prototype of the renderer options object. (KaTeX does not enable said prototype pollution. This advisory applies when combining KaTeX with other vulnerable software that allows for prototype pollution.) Affected versions may treat inherited properties from Object.prototype as renderer options, internal setting metadata, or namespace entries. In particular, an inherited trust value will be treated as though the application explicitly enabled trusted rendering, rather than using the documented default of false. With attacker-controlled mathematical expressions, this can produce links capable of user-interaction cross-site scripting or load attacker-selected external resources. Exploitation requires the consuming application to insert KaTeX output into a web page without a separate sanitizer. (KaTeX does not execute…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-238p-pmpm-9mq7

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-238p-pmpm-9mq7

  4. Revision 1 · created ·

    Published from ghsa record GHSA-238p-pmpm-9mq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-103923

Advisory: KaTeX: Existing prototype pollution can bypass trust restrictions
IDs: CVE-2026-103923, GHSA-238p-pmpm-9mq7
Record: https://patchnext.com/advisories/cve-2026-103923 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: katex 0.18.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm katex: affected >= 0.11.0, < 0.18.2; fixed in 0.18.2

## Suggested inspection (read-only)
- `npm ls katex --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on katex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-238p-pmpm-9mq7 (GitHub-reviewed advisory GHSA-238p-pmpm-9mq7 lists affected ranges: npm katex >=0.11.0 <0.18.2)
- Verified: https://osv.dev/vulnerability/GHSA-238p-pmpm-9mq7 (OSV record GHSA-238p-pmpm-9mq7 lists affected ranges: npm katex >=0.11.0 <0.18.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…