GraphQL Tools: TLS Certificate Validation Disabled in Legacy GraphQL WebSocket Executor
CVE-2026-103921GHSA-6fw5-9hq8-w87g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@graphql-tools/executor-legacy-ws 1.1.35), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @graphql-tools/executor-legacy-ws
- Affected
- <= 1.1.34
- Fixed in
- 1.1.35
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6fw5-9hq8-w87g lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6fw5-9hq8-w87g lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.35 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-103921: 0.27% estimated exploitation activity in the next 30 days; percentile 19.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact buildWSLegacyExecutor() in @graphql-tools/executor-legacy-ws previously hardcoded rejectUnauthorized: false when creating WebSocket connections over WSS. This disabled TLS certificate validation, allowing a network-positioned attacker to perform a Man-in-the-Middle (MITM) attack against applications that use this executor with a wss:// endpoint. Credentials passed via connectionParams or headers could be intercepted, and subscription data could be tampered with. Who is impacted: Applications using @graphql-tools/executor-legacy-ws (directly or via @graphql-tools/url-loader with SubscriptionProtocol.LEGACYWS) to connect to a wss:// endpoint from Node.js while sending authentication material over the connection. Browser WebSocket clients are unaffected by this option (browsers always validate certificates). Patches Upgrade to @graphql-tools/executor-legacy-ws@1.1.35 or later (and @graphql-tools/url-loader@9.1.9 or later if you use the loader). TLS certificate validation is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6fw5-9hq8-w87g
- Revision 2 · amended ·
Amended from osv record GHSA-6fw5-9hq8-w87g
- Revision 1 · created ·
Published from ghsa record GHSA-6fw5-9hq8-w87g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-103921 Advisory: GraphQL Tools: TLS Certificate Validation Disabled in Legacy GraphQL WebSocket Executor IDs: CVE-2026-103921, GHSA-6fw5-9hq8-w87g Record: https://patchnext.com/advisories/cve-2026-103921 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @graphql-tools/executor-legacy-ws 1.1.35. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @graphql-tools/executor-legacy-ws: affected <= 1.1.34; fixed in 1.1.35 ## Suggested inspection (read-only) - `npm ls @graphql-tools/executor-legacy-ws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @graphql-tools/executor-legacy-ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6fw5-9hq8-w87g (GitHub-reviewed advisory GHSA-6fw5-9hq8-w87g lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <=1.1.34) - Verified: https://osv.dev/vulnerability/GHSA-6fw5-9hq8-w87g (OSV record GHSA-6fw5-9hq8-w87g lists affected ranges: npm @graphql-tools/executor-legacy-ws >=0 <1.1.35 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…