next.js cache leak across root param values in nested 'use cache' functions
CVE-2026-103004GHSA-h694-7cp9-m8p3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 16.3.0, < 16.3.8
- Fixed in
- 16.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h694-7cp9-m8p3 lists affected ranges: npm next >=16.3.0 <16.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h694-7cp9-m8p3 lists affected ranges: npm next >=16.3.0 <16.3.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-103004: 0.25% estimated exploitation activity in the next 30 days; percentile 16.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact With Cache Components enabled (cacheComponents: true), a 'use cache' function that calls another 'use cache' function that reads a root param can be keyed incorrectly when the inner call is served from an existing entry: the enclosing function's cache key then omits that root param. The enclosing entry is written once and reused for all root param values, so a response for one root param value can serve content produced for a different value — whether the page is prerendered at build time or at runtime, or rendered dynamically. Shared cache headers let downstream caches redistribute the content further. What values are leaked cannot be attacker controlled. Which value's content is served depends only on which invocation wrote the entry first. Workarounds There are no known workarounds. Apps should upgrade to the patched version as soon as possible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from ghsa record GHSA-h694-7cp9-m8p3
- Revision 4 · amended ·
Amended from ghsa record GHSA-h694-7cp9-m8p3
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-h694-7cp9-m8p3
- Revision 1 · created ·
Published from ghsa record GHSA-h694-7cp9-m8p3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-103004 Advisory: next.js cache leak across root param values in nested 'use cache' functions IDs: CVE-2026-103004, GHSA-h694-7cp9-m8p3 Record: https://patchnext.com/advisories/cve-2026-103004 (revision 5, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 16.3.0, < 16.3.8; fixed in 16.3.8 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h694-7cp9-m8p3 (GitHub-reviewed advisory GHSA-h694-7cp9-m8p3 lists affected ranges: npm next >=16.3.0 <16.3.8) - Verified: https://osv.dev/vulnerability/GHSA-h694-7cp9-m8p3 (OSV record GHSA-h694-7cp9-m8p3 lists affected ranges: npm next >=16.3.0 <16.3.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…