TanStack Router: Unauthenticated reflected XSS in TanStack Start server-function responses
CVE-2026-102989GHSA-qx66-fv34-fjm8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tanstack/start-server-core 1.169.39; @tanstack/vue-start 1.168.56; @tanstack/solid-start 1.168.57; @tanstack/react-start 1.168.60), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @tanstack/start-server-core
- Affected
- >= 1.143.12, < 1.169.39
- Fixed in
- 1.169.39
- Affected
- >= 1.143.12, < 1.168.56
- Fixed in
- 1.168.56
- Affected
- >= 1.143.12, < 1.168.57
- Fixed in
- 1.168.57
- Affected
- >= 1.143.12, < 1.168.60
- Fixed in
- 1.168.60
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qx66-fv34-fjm8 lists affected ranges: npm @tanstack/start-server-core >=1.143.12 =1.143.12 =1.143.12 =1.143.12 <1.168.56
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qx66-fv34-fjm8 lists affected ranges: npm @tanstack/start-server-core >=1.143.12 =1.143.12 =1.143.12 =1.143.12 <1.168.56 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-102989: 0.54% estimated exploitation activity in the next 30 days; percentile 45.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthenticated attacker can craft a URL to a server function in an affected TanStack Start app. If someone opens the link, the app can return attacker-controlled HTML from its own origin and run the attacker's JavaScript there. The script can access same-origin data available to that visitor and make requests with their authority. Cause The server-function transport can pass request payload fields into internal middleware state instead of limiting them to public input fields. A malformed payload can leave an attacker-controlled result in the error path. Response handling can then treat a response-shaped object as an HTTP response. Affected versions Published versions of @tanstack/start-server-core, @tanstack/react-start, @tanstack/solid-start, and @tanstack/vue-start from 1.143.12 up to, but not including, their respective patched versions are affected. The patched versions are @tanstack/start-server-core@1.169.39, @tanstack/react-start@1.168.60,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qx66-fv34-fjm8
- Revision 2 · amended ·
Amended from osv record GHSA-qx66-fv34-fjm8
- Revision 1 · created ·
Published from ghsa record GHSA-qx66-fv34-fjm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102989 Advisory: TanStack Router: Unauthenticated reflected XSS in TanStack Start server-function responses IDs: CVE-2026-102989, GHSA-qx66-fv34-fjm8 Record: https://patchnext.com/advisories/cve-2026-102989 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @tanstack/start-server-core 1.169.39; @tanstack/vue-start 1.168.56; @tanstack/solid-start 1.168.57; @tanstack/react-start 1.168.60. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @tanstack/start-server-core: affected >= 1.143.12, < 1.169.39; fixed in 1.169.39 - npm @tanstack/vue-start: affected >= 1.143.12, < 1.168.56; fixed in 1.168.56 - npm @tanstack/solid-start: affected >= 1.143.12, < 1.168.57; fixed in 1.168.57 - npm @tanstack/react-start: affected >= 1.143.12, < 1.168.60; fixed in 1.168.60 ## Suggested inspection (read-only) - `npm ls @tanstack/start-server-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @tanstack/vue-start --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @tanstack/solid-start --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @tanstack/react-start --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @tanstack/start-server-core, @tanstack/vue-start, @tanstack/solid-start, @tanstack/react-start. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qx66-fv34-fjm8 (GitHub-reviewed advisory GHSA-qx66-fv34-fjm8 lists affected ranges: npm @tanstack/start-server-core >=1.143.12 =1.143.12 =1.143.12 =1.143.12 <1.168.56) - Verified: https://osv.dev/vulnerability/GHSA-qx66-fv34-fjm8 (OSV record GHSA-qx66-fv34-fjm8 lists affected ranges: npm @tanstack/start-server-core >=1.143.12 =1.143.12 =1.143.12 =1.143.12 <1.168.56 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…