Skip to content

← Actionable
Medium, CVSS 5.8amended

virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection

CVE-2026-102938GHSA-9h9j-4vrj-gf7g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.7.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-102938: 0.15% estimated exploitation activity in the next 30 days; percentile 3.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pyvenv.cfg is a line-based format with no escape syntax. PyEnvCfg.write() wrote values verbatim, while PyEnvCfg.readvalues() parses the file with str.splitlines(). A value containing a line boundary therefore became additional configuration lines, and because reading is last-wins, the injected keys replaced any key written earlier in the file. Impact The prompt value is the reachable input: it is set by --prompt, by the VIRTUALENVPROMPT environment variable, or from the config file, and write() emits prompt before home. A crafted prompt can therefore set home in the generated pyvenv.cfg: home is what tooling reads to locate the base interpreter, so a consumer that trusts it can be pointed elsewhere. implementation, versioninfo, version, executable, command and virtualenv are also written before prompt and can be replaced the same way. This requires the prompt to come from somewhere other than the person running the command, for example a CI job templating a branch name into…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-9h9j-4vrj-gf7g

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-9h9j-4vrj-gf7g

  4. Revision 1 · created ·

    Published from ghsa record GHSA-9h9j-4vrj-gf7g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102938

Advisory: virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection
IDs: CVE-2026-102938, GHSA-9h9j-4vrj-gf7g
Record: https://patchnext.com/advisories/cve-2026-102938 (revision 4, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.7.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected <= 21.7.10; fixed in 21.7.11

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9h9j-4vrj-gf7g (GitHub-reviewed advisory GHSA-9h9j-4vrj-gf7g lists affected ranges: PyPI virtualenv >=0 <=21.7.10)
- Verified: https://osv.dev/vulnerability/GHSA-9h9j-4vrj-gf7g (OSV record GHSA-9h9j-4vrj-gf7g lists affected ranges: PyPI virtualenv >=0 <21.7.11 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…