virtualenv: Command injection via --prompt in activate.bat (batch activator)
CVE-2026-102937GHSA-x78j-v8h9-3j2q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.7.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI virtualenv
- Affected
- <= 21.7.11
- Fixed in
- 21.7.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x78j-v8h9-3j2q lists affected ranges: PyPI virtualenv >=0 <=21.7.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x78j-v8h9-3j2q lists affected ranges: PyPI virtualenv >=0 <21.7.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-102937: 0.21% estimated exploitation activity in the next 30 days; percentile 10.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
BatchActivator.quote() returned its input unchanged, the only activator with no escaping at all. --prompt, the VIRTUALENVPROMPT environment variable, and the config file all set the prompt, and activate.bat writes it straight into @set "VAR=value". A prompt containing a double quote closes that string early, and whatever follows runs as live cmd.exe syntax: runs calc the moment someone activates the environment. Confirmed on a real Windows runner. Anyone who templates a prompt from untrusted input (a CI job using a branch name, a wrapper script deriving an environment name from user input) hands an attacker code execution in the shell of anyone who activates the resulting venv on Windows. Fixed in 21.7.12 by escaping the characters cmd.exe treats as live syntax inside this construct. Fix: https://github.com/pypa/virtualenv/pull/3250
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-x78j-v8h9-3j2q
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-x78j-v8h9-3j2q
- Revision 1 · created ·
Published from ghsa record GHSA-x78j-v8h9-3j2q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102937 Advisory: virtualenv: Command injection via --prompt in activate.bat (batch activator) IDs: CVE-2026-102937, GHSA-x78j-v8h9-3j2q Record: https://patchnext.com/advisories/cve-2026-102937 (revision 4, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.7.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI virtualenv: affected <= 21.7.11; fixed in 21.7.12 ## Suggested inspection (read-only) - `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on virtualenv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x78j-v8h9-3j2q (GitHub-reviewed advisory GHSA-x78j-v8h9-3j2q lists affected ranges: PyPI virtualenv >=0 <=21.7.11) - Verified: https://osv.dev/vulnerability/GHSA-x78j-v8h9-3j2q (OSV record GHSA-x78j-v8h9-3j2q lists affected ranges: PyPI virtualenv >=0 <21.7.12 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…