JupyterLab: Command link trust prompt in JupyterLab can trust a document other than the one clicked
CVE-2026-102832GHSA-jwrc-gm9j-263p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlite-core 0.8.4; jupyterlab 4.6.4, 4.5.11; notebook 7.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterlite-core
- Affected
- >= 0.7.5, <= 0.8.3
- Fixed in
- 0.8.4
PyPI jupyterlab
- Affected
- >= 4.6.0, <= 4.6.3>= 4.5.7, <= 4.5.10
- Fixed in
- 4.5.11, 4.6.4
PyPI notebook
- Affected
- >= 7.5.6, <= 7.6.2
- Fixed in
- 7.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwrc-gm9j-263p lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.7 =7.5.6 =0.7.5 <=0.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jwrc-gm9j-263p lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.7 =7.5.6 =0.7.5 <0.8.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-102832: 0.14% estimated exploitation activity in the next 30 days; percentile 3.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A Markdown file or a notebook output can carry a button that runs a JupyterLab command. Since 4.5.7 the first click on such a button opens a prompt naming the command, with Cancel, Run Once and Trust. Choosing Trust runs the command and marks the document trusted, so its later buttons run without a prompt. Which document gets marked is decided when the user answers, not when they click. Both trust commands read whichever document is current at that moment: markdownviewer:trust uses tracker.currentWidget, and notebook:trust uses the equivalent lookup. If another document becomes current while the prompt is open, that document is the one marked trusted, and the one the user was looking at stays untrusted. Users are affected if all of the following are true: - they run JupyterLab 4.5.7 through 4.6.3, or an application that bundles it such as Notebook 7.5+; - they open a Markdown file or notebook from someone else and click a button in it; - they answer Trust rather than…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jwrc-gm9j-263p
- Revision 2 · amended ·
Amended from osv record GHSA-jwrc-gm9j-263p
- Revision 1 · created ·
Published from ghsa record GHSA-jwrc-gm9j-263p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102832 Advisory: JupyterLab: Command link trust prompt in JupyterLab can trust a document other than the one clicked IDs: CVE-2026-102832, GHSA-jwrc-gm9j-263p Record: https://patchnext.com/advisories/cve-2026-102832 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterlite-core 0.8.4; jupyterlab 4.6.4, 4.5.11; notebook 7.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterlite-core: affected >= 0.7.5, <= 0.8.3; fixed in 0.8.4 - PyPI jupyterlab: affected >= 4.6.0, <= 4.6.3; >= 4.5.7, <= 4.5.10; fixed in 4.5.11, 4.6.4 - PyPI notebook: affected >= 7.5.6, <= 7.6.2; fixed in 7.6.3 ## Suggested inspection (read-only) - `python -m pip show jupyterlite-core`: prints the installed version. Run with the environment that serves production active. - `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active. - `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterlite-core, jupyterlab, notebook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jwrc-gm9j-263p (GitHub-reviewed advisory GHSA-jwrc-gm9j-263p lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.7 =7.5.6 =0.7.5 <=0.8.3) - Verified: https://osv.dev/vulnerability/GHSA-jwrc-gm9j-263p (OSV record GHSA-jwrc-gm9j-263p lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.7 =7.5.6 =0.7.5 <0.8.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…