Skip to content

← Actionable
High, CVSS 8.1amended

JupyterLab: Cross-site scripting (XSS) in JupyterLab via notebook cells pasted from the system clipboard

CVE-2026-102831GHSA-6966-vjj6-99xv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlite-core 0.8.4; jupyterlite 0.8.4; jupyterlab 4.6.4, 4.5.11; notebook 7.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlite-core

    Affected
    >= 0.7.0, <= 0.8.3
    Fixed in
    0.8.4
  • PyPI jupyterlite

    Affected
    >= 0.7.0, <= 0.8.3
    Fixed in
    0.8.4
  • PyPI jupyterlab

    Affected
    >= 4.6.0, <= 4.6.3>= 4.5.0, <= 4.5.10
    Fixed in
    4.5.11, 4.6.4
  • PyPI notebook

    Affected
    >= 7.5.0, <= 7.6.2
    Fixed in
    7.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-102831: 0.24% estimated exploitation activity in the next 30 days; percentile 14.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description JupyterLab 4.5.0 enabled copying and pasing cells through the system clipboard. The paste path parses clipboard text as cell JSON and inserts the cells without clearing metadata.trusted, so a payload can declare its own output as trusted. JupyterLab does not sanitize a trusted output and evaluates the <script elements it contains, so pasting the cell runs attacker's JavaScript in the JupyterLab origin. The same payload with "trusted": false is sanitized. Users are affected if all of the following are true: - they run JupyterLab 4.5.0 through 4.6.3, or an application that bundles it such as Notebook 7.5+; - if running 4.5.2 or newer, useSystemClipboardForCells is enabled - it is off by default in 4.5.2+, and always enabled on 4.5.0 and 4.5.1 with no opt-out - they run a Paste Cells command (e.g. from context menu, command palette, shortcut) while attacker-controlled text is in the clipboard; and - pasteCodeCellsWithoutOutput is off, the default, so the pasted cell keeps…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6966-vjj6-99xv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6966-vjj6-99xv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6966-vjj6-99xv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102831

Advisory: JupyterLab: Cross-site scripting (XSS) in JupyterLab via notebook cells pasted from the system clipboard
IDs: CVE-2026-102831, GHSA-6966-vjj6-99xv
Record: https://patchnext.com/advisories/cve-2026-102831 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlite-core 0.8.4; jupyterlite 0.8.4; jupyterlab 4.6.4, 4.5.11; notebook 7.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlite-core: affected >= 0.7.0, <= 0.8.3; fixed in 0.8.4
- PyPI jupyterlite: affected >= 0.7.0, <= 0.8.3; fixed in 0.8.4
- PyPI jupyterlab: affected >= 4.6.0, <= 4.6.3; >= 4.5.0, <= 4.5.10; fixed in 4.5.11, 4.6.4
- PyPI notebook: affected >= 7.5.0, <= 7.6.2; fixed in 7.6.3

## Suggested inspection (read-only)
- `python -m pip show jupyterlite-core`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show jupyterlite`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlite-core, jupyterlite, jupyterlab, notebook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6966-vjj6-99xv (GitHub-reviewed advisory GHSA-6966-vjj6-99xv lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.0 =7.5.0 =0.7.0 =0.7.0 <=0.8.3)
- Verified: https://osv.dev/vulnerability/GHSA-6966-vjj6-99xv (OSV record GHSA-6966-vjj6-99xv lists affected ranges: PyPI jupyterlab >=4.6.0 =4.5.0 =7.5.0 =0.7.0 =0.7.0 <0.8.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…