Skip to content

← Actionable
Medium, CVSS 6.8amended

JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)

CVE-2026-102830GHSA-3jqq-pw4j-pqcj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlite-core 0.8.4; jupyterlab 4.6.4, 4.5.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlite-core

    Affected
    <= 0.8.3
    Fixed in
    0.8.4
  • PyPI jupyterlab

    Affected
    >= 4.6.0, <= 4.6.3>= 3.0.0, <= 4.5.10
    Fixed in
    4.5.11, 4.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-102830: 0.26% estimated exploitation activity in the next 30 days; percentile 17.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description A language pack ships a Plural-Forms header saying how the language counts, for example nplurals=2; plural=(n != 1);. JupyterLab turns that string into a function with new Function, so the header gets executed. The check that meant to keep it safe was a regular expression. The regex was anchored at the start but not at the end, so it accepted any string that began with a valid plural rule and ignored everything after it. A header such as the following passed the check, and the part after the plural rule ran in the JupyterLab page as soon as the first plural string was translated: Users are affected if all of the following are true: - they run JupyterLab 3.0.0 through 4.6.3, or an application that bundles it such as Notebook 7; - a language pack they did not write is installed in the environment; and - that language is selected, so its catalogue is loaded An installation using the default English locale loads no catalogue and is not affected. CVE assignment pending, GitHub…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3jqq-pw4j-pqcj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3jqq-pw4j-pqcj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3jqq-pw4j-pqcj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102830

Advisory: JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)
IDs: CVE-2026-102830, GHSA-3jqq-pw4j-pqcj
Record: https://patchnext.com/advisories/cve-2026-102830 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlite-core 0.8.4; jupyterlab 4.6.4, 4.5.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlite-core: affected <= 0.8.3; fixed in 0.8.4
- PyPI jupyterlab: affected >= 4.6.0, <= 4.6.3; >= 3.0.0, <= 4.5.10; fixed in 4.5.11, 4.6.4

## Suggested inspection (read-only)
- `python -m pip show jupyterlite-core`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlite-core, jupyterlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3jqq-pw4j-pqcj (GitHub-reviewed advisory GHSA-3jqq-pw4j-pqcj lists affected ranges: PyPI jupyterlab >=4.6.0 =3.0.0 =0 <=0.8.3)
- Verified: https://osv.dev/vulnerability/GHSA-3jqq-pw4j-pqcj (OSV record GHSA-3jqq-pw4j-pqcj lists affected ranges: PyPI jupyterlab >=4.6.0 =3.0.0 =0 <0.8.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…