Skip to content

← Actionable
Critical, CVSS 9.2amended

simple-git unsafe-operation guard does not block trailer command configuration

CVE-2026-102828GHSA-x6jw-m9v5-85vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-git 4.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm simple-git

    Affected
    >= 3.15.0, < 4.0.1
    Fixed in
    4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-102828: 0.37% estimated exploitation activity in the next 30 days; percentile 30.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected product The default blockUnsafeOperationsPlugin in simple-git when an application permits untrusted values to reach SimpleGitOptions.config or Git inline configuration arguments such as -c <key=<value. Summary trailer.<token.cmd is not recognized as unsafe by the default guard. Therefore, a configured inline value reaches Git without a GitPluginError. Git documents trailer.<token.cmd as a shell command invoked by git interpret-trailers. An application that relies on the default plugin to reject unsafe configuration can therefore execute a command supplied through an untrusted trailer-command configuration value. Technical details simple-git/src/lib/git-factory.ts installs commandConfigPrefixingPlugin before blockUnsafeOperationsPlugin. The prefixing plugin in simple-git/src/lib/plugins/command-config-prefixing-plugin.ts turns every SimpleGitOptions.config entry into -c <key=<value before the unsafe-operation plugin evaluates the final argv. In simple-git@3.36.0,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-x6jw-m9v5-85vh

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-x6jw-m9v5-85vh

  4. Revision 1 · created ·

    Published from ghsa record GHSA-x6jw-m9v5-85vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102828

Advisory: simple-git unsafe-operation guard does not block trailer command configuration
IDs: CVE-2026-102828, GHSA-x6jw-m9v5-85vh
Record: https://patchnext.com/advisories/cve-2026-102828 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simple-git 4.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm simple-git: affected >= 3.15.0, < 4.0.1; fixed in 4.0.1

## Suggested inspection (read-only)
- `npm ls simple-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simple-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x6jw-m9v5-85vh (GitHub-reviewed advisory GHSA-x6jw-m9v5-85vh lists affected ranges: npm simple-git >=3.15.0 <4.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-x6jw-m9v5-85vh (OSV record GHSA-x6jw-m9v5-85vh lists affected ranges: npm simple-git >=3.15.0 <4.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…