Skip to content

← Actionable
High, CVSS 8.1amended

simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)

CVE-2026-102827GHSA-858h-whjf-mvg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-git 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-102827: 0.58% estimated exploitation activity in the next 30 days; percentile 47.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

simple-git's blockUnsafeOperationsPlugin blocks dangerous git options (--upload-pack/--receive-pack/--exec/...) unless the consumer opts in via unsafe:{allowUnsafePack:true}. Detection (@simple-git/argv-parser detectVulnerableFlags) matches the parsed flag NAME against literal-spelling patterns: /--(upload|receive)-pack/ (requires the literal '-pack') and the string '--exec'. But git accepts unambiguous prefix abbreviations of long options, and expandToken (token-expander.ts) returns the LITERAL token as flag.name (it uses the spec only for needsNext, never to canonicalize). So git push --receive-p=<cmd parses with flag.name='--receive-p', which /--(upload|receive)-pack/ does NOT match, yet git expands --receive-p - --receive-pack and runs <cmd (on a local/file remote, locally). The clone side is robust (its '--u' substring rule catches every --upload abbreviation); the push --receive- and --exe abbreviations have no equivalent rule and slip through. Proof of concept (latest:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-858h-whjf-mvg5

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-858h-whjf-mvg5

  3. Revision 2 · amended ·

    Amended from osv record GHSA-858h-whjf-mvg5

  4. Revision 1 · created ·

    Published from ghsa record GHSA-858h-whjf-mvg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102827

Advisory: simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
IDs: CVE-2026-102827, GHSA-858h-whjf-mvg5
Record: https://patchnext.com/advisories/cve-2026-102827 (revision 4, source checked 31 Oct 2026, 17:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simple-git 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm simple-git: affected <= 3.36.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls simple-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simple-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-858h-whjf-mvg5 (GitHub-reviewed advisory GHSA-858h-whjf-mvg5 lists affected ranges: npm simple-git >=0 <=3.36.0)
- Verified: https://osv.dev/vulnerability/GHSA-858h-whjf-mvg5 (OSV record GHSA-858h-whjf-mvg5 lists affected ranges: npm simple-git >=0 <4.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…