Skip to content

← Actionable
High, CVSS 8.1amended

simple-git allows command execution through unblocked Git configuration includes

CVE-2026-102826GHSA-g4wm-2vf7-vfgr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-git 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-102826: 0.46% estimated exploitation activity in the next 30 days; percentile 40.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An OS command injection vulnerability in git.clone() allows any application that flows attacker-influenced data into customArgs to execute arbitrary code. simple-git 3.36.0 (current latest on npm) ships without any include.path entry in the blockUnsafeOperationsPlugin denylist. Passing -c include.path=<file via customArgs loads any local file as a gitconfig. The loaded file can set core.sshCommand (or any otherwise-denied key), and the next remote operation in the same clone executes the attacker's command. PR #1167 (merged to main 2026-05-10, not yet released to npm) adds preventConfigBuilder('include.path', 'allowUnsafeInclude') to the denylist. The generated regex /\sinclude.path/ closes the plain spelling but does not match the conditional form includeIf.<cond.path. The variant therefore survives the upcoming release if the regex is not tightened in the same cycle. This sits in the same denylist class as the prior incomplete-fix chain (CVE-2022-24433, CVE-2022-24066,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g4wm-2vf7-vfgr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g4wm-2vf7-vfgr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g4wm-2vf7-vfgr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102826

Advisory: simple-git allows command execution through unblocked Git configuration includes
IDs: CVE-2026-102826, GHSA-g4wm-2vf7-vfgr
Record: https://patchnext.com/advisories/cve-2026-102826 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simple-git 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm simple-git: affected <= 3.36.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls simple-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simple-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g4wm-2vf7-vfgr (GitHub-reviewed advisory GHSA-g4wm-2vf7-vfgr lists affected ranges: npm simple-git >=0 <=3.36.0)
- Verified: https://osv.dev/vulnerability/GHSA-g4wm-2vf7-vfgr (OSV record GHSA-g4wm-2vf7-vfgr lists affected ranges: npm simple-git >=0 <4.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…