Skip to content

← Actionable
Medium, CVSS 4.3amended

Russh: Missing X25519 zero-point validation in hybrid ML-KEM key exchange

CVE-2026-102824GHSA-w3jg-pjxf-73p4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.63.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io russh

    Affected
    < 0.63.0
    Fixed in
    0.63.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-102824: 0.14% estimated exploitation activity in the next 30 days; percentile 3.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability The hybrid ML-KEM 768 + X25519 key exchange implementation in russh/src/kex/hybridmlkem.rs does not validate that the remote peer's X25519 public key is not the zero point (all-zero 32-byte value). This allows a remote peer to force the X25519 contribution to the combined shared secret to zero, reducing the hybrid KEX to a single-algorithm exchange. Affected code at HEAD (v0.62.4, commit 0089c89): Server-side (serverdh, lines 92-93): Client-side (computesharedsecret, lines 154-155): Root Cause Commit a7fc1eb (2026-07-22, "fix mpint encoding and validate curve25519 keys") added zero-point validation to the standalone Curve25519 KEX in russh/src/kex/curve25519.rs at two locations: - serverdh line 77: if clientpubkey.0 == [0u8; 32] { return Err(crate::Error::Kex); } - computesharedsecret line 122: if remotepubkey.0 == [0u8; 32] { return Err(crate::Error::Kex); } The same X25519 scalar multiplication pattern appears in hybridmlkem.rs, but the fix was not applied there.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w3jg-pjxf-73p4

  2. Revision 1 · created ·

    Published from osv record GHSA-w3jg-pjxf-73p4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102824

Advisory: Russh: Missing X25519 zero-point validation in hybrid ML-KEM key exchange
IDs: CVE-2026-102824, GHSA-w3jg-pjxf-73p4
Record: https://patchnext.com/advisories/cve-2026-102824 (revision 2, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: russh 0.63.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io russh: affected < 0.63.0; fixed in 0.63.0

## Suggested inspection (read-only)
- crates.io russh: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on russh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w3jg-pjxf-73p4 (OSV record GHSA-w3jg-pjxf-73p4 lists affected ranges: crates.io russh >=0 <0.63.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w3jg-pjxf-73p4 (GitHub-reviewed advisory GHSA-w3jg-pjxf-73p4 lists affected ranges: crates.io russh >=0 <0.63.0)

Commands are suggestions: review each one before running it.

Loading voting…