Skip to content

← Actionable
High, CVSS 7.5

OmniFaces: Forged combined-resource IDs and related output/push boundaries

CVE-2026-102695GHSA-fp43-vj7g-pg92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.omnifaces:omnifaces 5.4.2, 4.7.12, 3.14.23, 2.7.33, 1.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.omnifaces:omnifaces

    Affected
    < 1.14.3>= 2.0.0, < 2.7.33>= 3.0.0, < 3.14.23>= 4.0.0, < 4.7.12>= 5.0.0, < 5.4.2
    Fixed in
    5.4.2, 2.7.33, 4.7.12, 1.14.3, 3.14.23

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-102695: 0.31% estimated exploitation activity in the next 30 days; percentile 23.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

1. Forged combined-resource IDs CombinedResourceInfo accepts a path-derived ID without an authenticity check, inflates it without an output limit, converts it to attacker-selected resource identifiers, and retains unique IDs in an unbounded static cache. In bounded tests, 20,754 encoded bytes inflated to 16,000,000 characters (about 770:1; about 49 MB observed heap delta), and 200 unique IDs added 200 permanent cache entries. A legitimately shaped short ID remained about 1:1, while malformed input was rejected; the missing distinction is between a server-issued ID and an attacker-minted but structurally valid ID. The minimal application also confirmed three sink tails from the same forged-ID root: - A wildcard CDN mapping performed a server-side fetch and relayed the exact loopback-canary body. This requires the documented combined-resource and wildcard-CDN configuration. - A forged inner .xhtml resource bypassed the excluded-resource boundary and returned its raw content. - A forged…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fp43-vj7g-pg92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102695

Advisory: OmniFaces: Forged combined-resource IDs and related output/push boundaries
IDs: CVE-2026-102695, GHSA-fp43-vj7g-pg92
Record: https://patchnext.com/advisories/cve-2026-102695 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.omnifaces:omnifaces 5.4.2, 4.7.12, 3.14.23, 2.7.33, 1.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.omnifaces:omnifaces: affected < 1.14.3; >= 2.0.0, < 2.7.33; >= 3.0.0, < 3.14.23; >= 4.0.0, < 4.7.12; >= 5.0.0, < 5.4.2; fixed in 5.4.2, 2.7.33, 4.7.12, 1.14.3, 3.14.23

## Suggested inspection (read-only)
- Maven org.omnifaces:omnifaces: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.omnifaces:omnifaces.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fp43-vj7g-pg92 (GitHub-reviewed advisory GHSA-fp43-vj7g-pg92 lists affected ranges: Maven org.omnifaces:omnifaces >=0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.4.2)

Commands are suggestions: review each one before running it.

Loading voting…