Pipecat: Public exposure of Pipecat’s development runner can allow unauthenticated bot session creation
CVE-2026-102682GHSA-hqm2-cfx2-2vgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pipecat-ai 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pipecat-ai
- Affected
- >= 0.0.98, <= 1.5.0
- Fixed in
- 1.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hqm2-cfx2-2vgh lists affected ranges: PyPI pipecat-ai >=0.0.98 <=1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hqm2-cfx2-2vgh lists affected ranges: PyPI pipecat-ai >=0.0.98 <1.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-102682: 0.23% estimated exploitation activity in the next 30 days; percentile 14.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pipecat’s built-in development runner exposes endpoints that create bot sessions and, for the Daily transport, paid Daily rooms. These development endpoints intentionally do not authenticate callers. The runner binds to localhost by default and is designed exclusively for local development. It is not built or supported as a production server. Exploitation therefore requires an operator to deliberately make the development runner reachable from an untrusted network, such as by setting --host 0.0.0.0, publishing its port, or using a public tunnel without access controls. If exposed in this way, an unauthenticated caller may invoke endpoints including /start, /daily, and /daily-dialin-webhook. Depending on the endpoint and configuration, this can create a bot session or Daily room and may return a room URL and join token. Repeated requests may also consume local resources and third-party service quotas. The consequences of interacting with a launched bot depend on that bot’s…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hqm2-cfx2-2vgh
- Revision 2 · amended ·
Amended from osv record GHSA-hqm2-cfx2-2vgh
- Revision 1 · created ·
Published from ghsa record GHSA-hqm2-cfx2-2vgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102682 Advisory: Pipecat: Public exposure of Pipecat’s development runner can allow unauthenticated bot session creation IDs: CVE-2026-102682, GHSA-hqm2-cfx2-2vgh Record: https://patchnext.com/advisories/cve-2026-102682 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pipecat-ai 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pipecat-ai: affected >= 0.0.98, <= 1.5.0; fixed in 1.6.0 ## Suggested inspection (read-only) - `python -m pip show pipecat-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pipecat-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hqm2-cfx2-2vgh (GitHub-reviewed advisory GHSA-hqm2-cfx2-2vgh lists affected ranges: PyPI pipecat-ai >=0.0.98 <=1.5.0) - Verified: https://osv.dev/vulnerability/GHSA-hqm2-cfx2-2vgh (OSV record GHSA-hqm2-cfx2-2vgh lists affected ranges: PyPI pipecat-ai >=0.0.98 <1.6.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…