Skip to content

← Actionable
Medium, CVSS 5.3amended

Gotify: Insufficiently Protected Password Change endpoint

CVE-2026-102603GHSA-3hcj-9m7p-wwm9

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/gotify/server

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/gotify/server/v3

    Affected
    < 3.0.0
    Fixed in
    3.0.0
  • Go github.com/gotify/server/v2

    Affected
    <= 2.9.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-102603: 0.34% estimated exploitation activity in the next 30 days; percentile 26.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The password change endpoint (POST /current/user/password) in Gotify versions <= 2.9.1 does not require knowledge of the current password. An attacker in possession of a valid client token can set a new password for the affected user. Recovering the account requires administrator intervention or direct database access. PoC Mitigation - Upgrade to Gotify 3.0.0, which introduces step-up authentication: changing the password now requires re-authenticating with the account password, or - Restrict access to the state-changing endpoints under /user and /current/user to trusted networks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-3hcj-9m7p-wwm9

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6772

  4. Revision 1 · created ·

    Published from osv record GHSA-3hcj-9m7p-wwm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102603

Advisory: Gotify: Insufficiently Protected Password Change endpoint
IDs: CVE-2026-102603, GHSA-3hcj-9m7p-wwm9
Record: https://patchnext.com/advisories/cve-2026-102603 (revision 4, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/gotify/server/v3 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/gotify/server: affected every version
- Go github.com/gotify/server/v3: affected < 3.0.0; fixed in 3.0.0
- Go github.com/gotify/server/v2: affected <= 2.9.1

## Suggested inspection (read-only)
- Go github.com/gotify/server: check the installed version with your package manager.
- Go github.com/gotify/server/v3: check the installed version with your package manager.
- Go github.com/gotify/server/v2: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/gotify/server, github.com/gotify/server/v3, github.com/gotify/server/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6772 (OSV record GO-2026-6772 lists affected ranges: Go github.com/gotify/server >=0; Go github.com/gotify/server/v2 >=0; Go github.com/gotify/server/v3 >=0 <3.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-3hcj-9m7p-wwm9 (OSV record GHSA-3hcj-9m7p-wwm9 lists affected ranges: Go github.com/gotify/server/v2 >=0 =0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3hcj-9m7p-wwm9 (GitHub-reviewed advisory GHSA-3hcj-9m7p-wwm9 lists affected ranges: Go github.com/gotify/server/v2 >=0 =0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…