Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter
CVE-2026-102601GHSA-cxf4-7mrp-vvpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/flysystem 3.35.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist league/flysystem
- Affected
- <= 3.35.2
- Fixed in
- 3.35.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cxf4-7mrp-vvpr lists affected ranges: Packagist league/flysystem >=0 <3.35.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cxf4-7mrp-vvpr lists affected ranges: Packagist league/flysystem >=0 <=3.35.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-102601: 0.34% estimated exploitation activity in the next 30 days; percentile 27.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Related public issue (context, not a duplicate) Closed issue #1429 ("Handle non-UTF-8 paths", 2024-03-24) raised exactly this general concern and even suggested detection via pregmatch('//u', $path) !== 1 -- note the reporter's suggested check explicitly compares !== 1, which would correctly treat PCRE's false return as "reject." The maintainer's reply pointed to the PathNormalizer interface as the place to implement this. The control-character check that ended up shipping in WhitespacePathNormalizer (if (pregmatch('#\p{C}+#u', $unixPath))) addresses the general concern but does not use the !== 1-style comparison the original issue suggested -- it uses a bare truthy check, which is exactly the gap this report demonstrates. So this is not a duplicate of #1429; it's a concrete bypass surviving in the fix that issue's concern led to. Vulnerability Details File: src/WhitespacePathNormalizer.php, lines 22-28 (normalizePath()) -- the default PathNormalizer used by Filesystem for every…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cxf4-7mrp-vvpr
- Revision 1 · created ·
Published from osv record GHSA-cxf4-7mrp-vvpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102601 Advisory: Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter IDs: CVE-2026-102601, GHSA-cxf4-7mrp-vvpr Record: https://patchnext.com/advisories/cve-2026-102601 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: league/flysystem 3.35.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist league/flysystem: affected <= 3.35.2; fixed in 3.35.3 ## Suggested inspection (read-only) - Packagist league/flysystem: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on league/flysystem. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cxf4-7mrp-vvpr (OSV record GHSA-cxf4-7mrp-vvpr lists affected ranges: Packagist league/flysystem >=0 <3.35.3 (fixed)) - Verified: https://github.com/advisories/GHSA-cxf4-7mrp-vvpr (GitHub-reviewed advisory GHSA-cxf4-7mrp-vvpr lists affected ranges: Packagist league/flysystem >=0 <=3.35.2) Commands are suggestions: review each one before running it.
Loading voting…