Skip to content

← Actionable
High, CVSS 7.5amended

Socket.IO: Engine.IO Protocol Revision Mismatch DoS

CVE-2026-102599GHSA-2gc4-cqfq-p2gv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (engine.io 6.6.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm engine.io

    Affected
    >= 6.6.0, < 6.6.10
    Fixed in
    6.6.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-102599: 0.58% estimated exploitation activity in the next 30 days; percentile 47.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial-of-service vulnerability exists in Engine.IO / Socket.IO servers that allow transport upgrades. The Engine.IO protocol revision is negotiated during the initial handshake and stored on the session, but a newly-created transport, including a WebSocket upgrade transport, could independently derive a different protocol revision from the upgrade request query parameters. The server did not verify that the protocol revision of an upgrade request matched the protocol revision of the existing session. A malicious client could exploit this mismatch by establishing a valid Engine.IO session and then sending an upgrade request with a different, or omitted, EIO query parameter. This could cause the server to attach a transport using a parser and heartbeat behavior inconsistent with the session. Under some conditions, a crafted heartbeat packet could trigger an uncaught exception and terminate the Node.js process. Servers using the default Engine.IO v4 protocol are impacted. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2gc4-cqfq-p2gv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2gc4-cqfq-p2gv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2gc4-cqfq-p2gv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102599

Advisory: Socket.IO: Engine.IO Protocol Revision Mismatch DoS
IDs: CVE-2026-102599, GHSA-2gc4-cqfq-p2gv
Record: https://patchnext.com/advisories/cve-2026-102599 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: engine.io 6.6.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm engine.io: affected >= 6.6.0, < 6.6.10; fixed in 6.6.10

## Suggested inspection (read-only)
- `npm ls engine.io --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on engine.io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2gc4-cqfq-p2gv (GitHub-reviewed advisory GHSA-2gc4-cqfq-p2gv lists affected ranges: npm engine.io >=6.6.0 <6.6.10)
- Verified: https://osv.dev/vulnerability/GHSA-2gc4-cqfq-p2gv (OSV record GHSA-2gc4-cqfq-p2gv lists affected ranges: npm engine.io >=6.6.0 <6.6.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…