Skip to content

← Actionable
Critical, CVSS 9.2amended

shell-quote: quote() command injection via a line terminator in a token after a { comment } token

CVE-2026-102422GHSA-pqg4-j6r4-53mv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shell-quote 1.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm shell-quote

    Affected
    >= 1.8.4, < 1.11.0
    Fixed in
    1.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-102422: 0.38% estimated exploitation activity in the next 30 days; percentile 31.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact quote() emits a { comment } token as

followed by its text, which comments out the rest of the shell line, including the opening quote of any later string token. A line terminator in that later string ends the comment, and the rest of the string is parsed as shell input: Passed to sh, bash, dash, ksh, or zsh, this runs id. parse() emits a comment token for a

in the middle of a word (for example http://example.com/#frag), so callers that combine parse() output with another untrusted string, such as quote(parse(untrustedCommand).concat(untrustedArg)), are affected. The fix for CVE-2026-9277 rejected line terminators in the comment's own text, but not in the tokens after it. Exploitation requires an attacker-controlled string containing a line terminator that follows a { comment } token in the same quote() call. Patches Fixed in v1.11.0: quote() throws a TypeError when a string after a { comment } token contains a line terminator (\n, \r, U+2028, or U+2029). Workarounds Drop…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-pqg4-j6r4-53mv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-pqg4-j6r4-53mv

  4. Revision 1 · created ·

    Published from ghsa record GHSA-pqg4-j6r4-53mv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102422

Advisory: shell-quote: `quote()` command injection via a line terminator in a token after a `{ comment }` token
IDs: CVE-2026-102422, GHSA-pqg4-j6r4-53mv
Record: https://patchnext.com/advisories/cve-2026-102422 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shell-quote 1.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm shell-quote: affected >= 1.8.4, < 1.11.0; fixed in 1.11.0

## Suggested inspection (read-only)
- `npm ls shell-quote --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shell-quote.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pqg4-j6r4-53mv (GitHub-reviewed advisory GHSA-pqg4-j6r4-53mv lists affected ranges: npm shell-quote >=1.8.4 <1.11.0)
- Verified: https://osv.dev/vulnerability/GHSA-pqg4-j6r4-53mv (OSV record GHSA-pqg4-j6r4-53mv lists affected ranges: npm shell-quote >=1.8.4 <1.11.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…