Skip to content

← Actionable
High, CVSS 7.5amended

Nest: Remote process termination via a deeply nested microservice message pattern

CVE-2026-102281GHSA-m8vh-jmq9-5rjg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nestjs/microservices 12.0.2, 11.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-102281: 0.59% estimated exploitation activity in the next 30 days; percentile 48.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

| Field | Value | | --- | --- | | Ecosystem | npm | | Package | @nestjs/microservices | | Affected versions | = 12.0.0, < 12.0.2 and < 11.2.4 | | Patched versions | 12.0.2 and 11.2.4 (upgrade to 12.0.3 / 11.2.5) | Summary A single message whose pattern is a deeply nested object terminates a NestJS microservice that uses the TCP or RabbitMQ transport. The server serialized the client-supplied pattern with JSON.stringify to derive the handler lookup key; on deeply nested input this throws RangeError: Maximum call stack size exceeded. The exception escaped the asynchronous message handler as an unhandled promise rejection, which terminates the Node.js process under the default --unhandled-rejections=throw. Impact Denial of service, one message per crash, repeatable. The attacker needs to be able to reach the transport: connect to the TCP transport's port, or publish to the queue or exchange the service consumes from. The TCP transport performs no authentication by default, so on a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m8vh-jmq9-5rjg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-m8vh-jmq9-5rjg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-m8vh-jmq9-5rjg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102281

Advisory: Nest: Remote process termination via a deeply nested microservice message pattern
IDs: CVE-2026-102281, GHSA-m8vh-jmq9-5rjg
Record: https://patchnext.com/advisories/cve-2026-102281 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nestjs/microservices 12.0.2, 11.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nestjs/microservices: affected < 11.2.4; >= 12.0.0, < 12.0.2; fixed in 11.2.4, 12.0.2

## Suggested inspection (read-only)
- `npm ls @nestjs/microservices --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nestjs/microservices.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m8vh-jmq9-5rjg (GitHub-reviewed advisory GHSA-m8vh-jmq9-5rjg lists affected ranges: npm @nestjs/microservices >=0 =12.0.0 <12.0.2)
- Verified: https://osv.dev/vulnerability/GHSA-m8vh-jmq9-5rjg (OSV record GHSA-m8vh-jmq9-5rjg lists affected ranges: npm @nestjs/microservices >=0 =12.0.0 <12.0.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…