Skip to content

← Actionable
Low, CVSS 3.1amended

Laravel: XSS in Debug Page Information

CVE-2026-102279GHSA-jh5r-qr3c-85q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 13.30.0, 12.69.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist laravel/framework

    Affected
    < 12.69.0>= 13.0.0, < 13.30.0
    Fixed in
    12.69.0, 13.30.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-102279: 0.26% estimated exploitation activity in the next 30 days; percentile 18.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When APPDEBUG=true, attacker-controlled input is passed to a Tippy.js tooltip configured with allowHTML: true, enabling DOM-based XSS during mouse hover. Patches #61381

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jh5r-qr3c-85q8

  2. Revision 1 · created ·

    Published from osv record GHSA-jh5r-qr3c-85q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102279

Advisory: Laravel: XSS in Debug Page Information
IDs: CVE-2026-102279, GHSA-jh5r-qr3c-85q8
Record: https://patchnext.com/advisories/cve-2026-102279 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/framework 13.30.0, 12.69.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/framework: affected < 12.69.0; >= 13.0.0, < 13.30.0; fixed in 12.69.0, 13.30.0

## Suggested inspection (read-only)
- Packagist laravel/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jh5r-qr3c-85q8 (OSV record GHSA-jh5r-qr3c-85q8 lists affected ranges: Packagist laravel/framework >=0 =13.0.0 <13.30.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jh5r-qr3c-85q8 (GitHub-reviewed advisory GHSA-jh5r-qr3c-85q8 lists affected ranges: Packagist laravel/framework >=0 =13.0.0 <13.30.0)

Commands are suggestions: review each one before running it.

Loading voting…