brace-expansion: DoS via uncontrolled recursion on nested brace groups causing stack exhaustion
CVE-2026-102278GHSA-qhr7-859c-m2p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (brace-expansion 5.0.11, 3.0.8, 2.1.6, 1.1.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm brace-expansion
- Affected
- >= 4.0.0, < 5.0.11>= 3.0.0, < 3.0.8>= 2.0.0, < 2.1.6< 1.1.20
- Fixed in
- 3.0.8, 1.1.20, 5.0.11, 2.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qhr7-859c-m2p7 lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qhr7-859c-m2p7 lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-102278: 0.49% estimated exploitation activity in the next 30 days; percentile 42.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary expand() recurses once per level of brace nesting. Deeply nested input exhausts the native stack and crashes the process. This is distinct from CVE-2026-14257 / GHSA-mh99-v99m-4gvg, which made the tail iterative (recursion on m.post, driven by how many groups are chained). Nesting depth drives a different recursion that the tail fix never touched, so the documented constant-stack-depth guarantee only ever covered chained input, not nested input. It is also distinct from GHSA-6j4f-fj2g-mc7p, which fixed recursion in parseCommaParts(). Both payloads below still crash with that fix applied. Two recursion sites Comma members. Each alternative of a brace set is expanded by a recursive call, so nesting a set inside every alternative recurses once per level: Crashes at depth 3,907 - about 15.6 KB of input. Single set. A brace set whose body parses to a single part is expanded by a recursive call before being re-wrapped (x{{a,b}}y - x{a}y x{b}y), which recurses once per nesting…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qhr7-859c-m2p7
- Revision 2 · amended ·
Amended from osv record GHSA-qhr7-859c-m2p7
- Revision 1 · created ·
Published from ghsa record GHSA-qhr7-859c-m2p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102278 Advisory: brace-expansion: DoS via uncontrolled recursion on nested brace groups causing stack exhaustion IDs: CVE-2026-102278, GHSA-qhr7-859c-m2p7 Record: https://patchnext.com/advisories/cve-2026-102278 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: brace-expansion 5.0.11, 3.0.8, 2.1.6, 1.1.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm brace-expansion: affected >= 4.0.0, < 5.0.11; >= 3.0.0, < 3.0.8; >= 2.0.0, < 2.1.6; < 1.1.20; fixed in 3.0.8, 1.1.20, 5.0.11, 2.1.6 ## Suggested inspection (read-only) - `npm ls brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on brace-expansion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qhr7-859c-m2p7 (GitHub-reviewed advisory GHSA-qhr7-859c-m2p7 lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.20) - Verified: https://osv.dev/vulnerability/GHSA-qhr7-859c-m2p7 (OSV record GHSA-qhr7-859c-m2p7 lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.20 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…