brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion
CVE-2026-102276GHSA-6j4f-fj2g-mc7p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (brace-expansion 5.0.10, 3.0.7, 2.1.5, 1.1.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm brace-expansion
- Affected
- >= 4.0.0, < 5.0.10>= 3.0.0, < 3.0.7>= 2.0.0, < 2.1.5< 1.1.19
- Fixed in
- 5.0.10, 2.1.5, 1.1.19, 3.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6j4f-fj2g-mc7p lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6j4f-fj2g-mc7p lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.19 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-102276: 0.46% estimated exploitation activity in the next 30 days; percentile 39.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary parseCommaParts() can exhaust the native stack and crash the process. There are two distinct ways to trigger it, both reachable from a single untrusted pattern string. This is the parsing-side counterpart to CVE-2026-14257 / GHSA-mh99-v99m-4gvg. That fix made expand() iterative and documented a constant-stack-depth guarantee, but parseCommaParts() was left recursive, so the guarantee only held for one of the two parsing paths. Vector 1 - unbounded recursion on post parseCommaParts() recursed on the remainder of the string once per brace group: A brace group containing many comma-separated groups drives one recursion level per group: About 7,300 repetitions - roughly 29 KB of input - is enough on Node 24; roughly 6,300 (25 KB) on Node 18. The threshold is identical on every affected release line. Vector 2 - push.apply with an unbounded array Even with the recursion removed, parseCommaParts() spread whole arrays into an argument list: Function.prototype.apply places one…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6j4f-fj2g-mc7p
- Revision 2 · amended ·
Amended from osv record GHSA-6j4f-fj2g-mc7p
- Revision 1 · created ·
Published from ghsa record GHSA-6j4f-fj2g-mc7p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-102276 Advisory: brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion IDs: CVE-2026-102276, GHSA-6j4f-fj2g-mc7p Record: https://patchnext.com/advisories/cve-2026-102276 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: brace-expansion 5.0.10, 3.0.7, 2.1.5, 1.1.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm brace-expansion: affected >= 4.0.0, < 5.0.10; >= 3.0.0, < 3.0.7; >= 2.0.0, < 2.1.5; < 1.1.19; fixed in 5.0.10, 2.1.5, 1.1.19, 3.0.7 ## Suggested inspection (read-only) - `npm ls brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on brace-expansion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6j4f-fj2g-mc7p (GitHub-reviewed advisory GHSA-6j4f-fj2g-mc7p lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.19) - Verified: https://osv.dev/vulnerability/GHSA-6j4f-fj2g-mc7p (OSV record GHSA-6j4f-fj2g-mc7p lists affected ranges: npm brace-expansion >=4.0.0 =3.0.0 =2.0.0 =0 <1.1.19 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…