Skip to content

← Actionable
Medium, CVSS 6.5amended

PyJWT accepts inconsistent OKP x/d JWKs, causing public/private key identity confusion

CVE-2026-102275GHSA-x33g-cr3x-6449

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    >= 2.1.0, <= 2.14.0
    Fixed in
    2.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-102275: 0.17% estimated exploitation activity in the next 30 days; percentile 5.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PyJWT accepts internally inconsistent OKP private JWKs where the declared public key x does not correspond to the supplied private key d. When d is present, OKPAlgorithm.fromjwk() constructs the Ed25519/Ed448 private key from d without verifying that the public key derived from d matches x. As a result, the original JWK can contain one public key identity while PyJWT performs cryptographic operations using a different key. In affected DPoP integrations, this can allow a stolen sender-constrained access token to be used without possession of the legitimate holder's private key. Details The vulnerable logic is in jwt/algorithms.py: When d is present, x is parsed but never compared with the public key derived from d. For example, PyJWT accepts: even though x and d belong to different key pairs. The behavior has existed since OKP private-JWK import was introduced: Ed25519: PyJWT 2.1.0+ Ed448: PyJWT 2.2.0+ Confirmed through PyJWT 2.14.0 and current master A correct import should…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x33g-cr3x-6449

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x33g-cr3x-6449

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x33g-cr3x-6449

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102275

Advisory: PyJWT accepts inconsistent OKP x/d JWKs, causing public/private key identity confusion
IDs: CVE-2026-102275, GHSA-x33g-cr3x-6449
Record: https://patchnext.com/advisories/cve-2026-102275 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected >= 2.1.0, <= 2.14.0; fixed in 2.15.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x33g-cr3x-6449 (GitHub-reviewed advisory GHSA-x33g-cr3x-6449 lists affected ranges: PyPI pyjwt >=2.1.0 <=2.14.0)
- Verified: https://osv.dev/vulnerability/GHSA-x33g-cr3x-6449 (OSV record GHSA-x33g-cr3x-6449 lists affected ranges: PyPI pyjwt >=2.1.0 <2.15.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…