Skip to content

← Actionable
Medium, CVSS 5.9amended

PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set

CVE-2026-102274GHSA-w6j9-cwv2-h6wq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    >= 2.9.0, <= 2.13.0
    Fixed in
    2.14.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-102274: 0.55% estimated exploitation activity in the next 30 days; percentile 46.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A malformed RSA JWK inside a JWK Set aborts parsing of the entire set instead of being skipped, because RSAAlgorithm.fromjwk can raise a plain ValueError that isn't caught by PyJWKSet's per-key error-skipping logic. Affected component / version - Package: PyJWT (PyPI, ecosystem pip) - Files: jwt/apijwk.py (PyJWK.init, PyJWKSet.init), jwt/algorithms.py (RSAAlgorithm.fromjwk) - Confirmed present in the master branch as of 2026-09-05 (commit 7144e4534c34810f4525dc4578a32addd8212cff, tag 2.13.0). Directly verified identical in tags 2.9.0, 2.10.0, 2.11.0, 2.12.0, 2.12.1, 2.13.0 -- the vulnerable call and the except PyJWTError guard are unchanged across all six releases. Not verified against any release prior to 2.9.0. Details PyJWKSet.init (jwt/apijwk.py:145-152) iterates each key in a JWK Set: PyJWK.init (apijwk.py:82) calls self.Algorithm.fromjwk(self.jwkdata) with no try/except of its own. For an RSA JWK, this dispatches to RSAAlgorithm.fromjwk (jwt/algorithms.py:539-586). When…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w6j9-cwv2-h6wq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-w6j9-cwv2-h6wq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-w6j9-cwv2-h6wq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102274

Advisory: PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set
IDs: CVE-2026-102274, GHSA-w6j9-cwv2-h6wq
Record: https://patchnext.com/advisories/cve-2026-102274 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected >= 2.9.0, <= 2.13.0; fixed in 2.14.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w6j9-cwv2-h6wq (GitHub-reviewed advisory GHSA-w6j9-cwv2-h6wq lists affected ranges: PyPI pyjwt >=2.9.0 <=2.13.0)
- Verified: https://osv.dev/vulnerability/GHSA-w6j9-cwv2-h6wq (OSV record GHSA-w6j9-cwv2-h6wq lists affected ranges: PyPI pyjwt >=2.9.0 <2.14.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…