Skip to content

← Actionable
High, CVSS 7.4amended

PyJWT BOM Bypass

CVE-2026-102272GHSA-r6x4-923q-g947

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    >= 2.13.0, <= 2.13.0
    Fixed in
    2.14.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-102272: 0.22% estimated exploitation activity in the next 30 days; percentile 12.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Package - Package: PyJWT (pyjwt on PyPI) - Repository: https://www.google.com/url?q=https://github.com/jpadilla/pyjwt&source=gmail&ust=1781794518474000&sa=E - Affected version: 2.13.0 - Vulnerability class: Algorithm confusion / patch bypass --- Root Cause PyJWT 2.13.0 introduced a guard in HMACAlgorithm.preparekey() (file jwt/algorithms.py, approximately line 344) to prevent RSA public key material from being used as an HMAC secret — the root cause of CVE-2026-48526. The guard uses bytes.lstrip() before calling startswith(b"{"): bytes.lstrip() with no argument removes only bytes in the ASCII whitespace set (\x20 \t \n \r \x0b \x0c). A UTF-8 BOM prefix (\xef\xbb\xbf) is not stripped, so stripped.startswith(b"{") returns False for any BOM-prefixed JWK JSON. The JWK detection block is never entered, and the RSA public key bytes are silently accepted as the HMAC-SHA256 secret. --- PoC Sketch (pseudocode — not a weaponized payload) --- Impact An unauthenticated network attacker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r6x4-923q-g947

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r6x4-923q-g947

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r6x4-923q-g947

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102272

Advisory: PyJWT BOM Bypass
IDs: CVE-2026-102272, GHSA-r6x4-923q-g947
Record: https://patchnext.com/advisories/cve-2026-102272 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected >= 2.13.0, <= 2.13.0; fixed in 2.14.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r6x4-923q-g947 (GitHub-reviewed advisory GHSA-r6x4-923q-g947 lists affected ranges: PyPI pyjwt >=2.13.0 <=2.13.0)
- Verified: https://osv.dev/vulnerability/GHSA-r6x4-923q-g947 (OSV record GHSA-r6x4-923q-g947 lists affected ranges: PyPI pyjwt >=2.13.0 <2.14.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…