Skip to content

← Actionable
High, CVSS 7.4amended

PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard

CVE-2026-102271GHSA-p4g4-x82p-q773

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    >= 2.4.0, < 2.14.0
    Fixed in
    2.14.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-102271: 0.21% estimated exploitation activity in the next 30 days; percentile 11.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HMACAlgorithm.preparekey blocks asymmetric keys from being used as HMAC secrets by searching for text markers only. It looks for -----BEGIN and for an ssh- prefix. The same key in DER form is binary ASN.1 and has neither marker, so it passes the check and is used as an HMAC secret. An application that verifies tokens with an RSA or EC public key, and also allows HS256 with that same key, can be given a forged token. The attacker signs it with the public key, which is public. This is the key confusion problem CVE-2022-29217 was filed for, reachable again through a different encoding. The reach is smaller than the original CVE. The application must already be in that misconfiguration, and it must hold its public key as DER bytes rather than PEM. Details The guard is at jwt/algorithms.py:331: Both helpers are text matchers. Neither one parses the key. - jwt/utils.py:126, ispemformat, runs a regex for ----[- ]BEGIN ...----. - jwt/utils.py:141, issshkey, checks startswith against…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p4g4-x82p-q773

  2. Revision 2 · amended ·

    Amended from osv record GHSA-p4g4-x82p-q773

  3. Revision 1 · created ·

    Published from ghsa record GHSA-p4g4-x82p-q773

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-102271

Advisory: PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard
IDs: CVE-2026-102271, GHSA-p4g4-x82p-q773
Record: https://patchnext.com/advisories/cve-2026-102271 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected >= 2.4.0, < 2.14.0; fixed in 2.14.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p4g4-x82p-q773 (GitHub-reviewed advisory GHSA-p4g4-x82p-q773 lists affected ranges: PyPI pyjwt >=2.4.0 <2.14.0)
- Verified: https://osv.dev/vulnerability/GHSA-p4g4-x82p-q773 (OSV record GHSA-p4g4-x82p-q773 lists affected ranges: PyPI pyjwt >=2.4.0 <2.14.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…