Skip to content

← Actionable
High, CVSS 7.4amended

@grpc/grpc-js: In certain configurations, getAuthContext can return unauthorized certificates as though they were authorized

CVE-2026-101916GHSA-m9gg-hp2v-232j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grpc/grpc-js 1.14.5, 1.13.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @grpc/grpc-js

    Affected
    < 1.13.6>= 1.14.0, < 1.14.5
    Fixed in
    1.14.5, 1.13.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-101916: 0.21% estimated exploitation activity in the next 30 days; percentile 12.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When server credentials are created with the requireClientCertificate option set to false, getAuthContext does not distinguish between authorized and unauthorized certificates in its return value. This can create improper authentication vulnerabilities for @grpc/grpc-js users who use the result of getAuthContext for authentication. In particular, @grpc/grpc-js-xds can both set the requireClientCertificate option to false and use the return value of getAuthContext for RBAC authentication in some configurations. Patches This vulenrability is fixed in 1.13.6 and 1.14.5. Workarounds @grpc/grpc-js users using getAuthContext this way can avoid this problem by setting requireClientCertificate to true. @grpc/grpc-js-xds users using RBAC can avoid this by setting the requireclientcertificate field to true in the DownstreamTlsContext in the xDS configuration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m9gg-hp2v-232j

  2. Revision 2 · amended ·

    Amended from osv record GHSA-m9gg-hp2v-232j

  3. Revision 1 · created ·

    Published from ghsa record GHSA-m9gg-hp2v-232j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-101916

Advisory: @grpc/grpc-js: In certain configurations, getAuthContext can return unauthorized certificates as though they were authorized
IDs: CVE-2026-101916, GHSA-m9gg-hp2v-232j
Record: https://patchnext.com/advisories/cve-2026-101916 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grpc/grpc-js 1.14.5, 1.13.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grpc/grpc-js: affected < 1.13.6; >= 1.14.0, < 1.14.5; fixed in 1.14.5, 1.13.6

## Suggested inspection (read-only)
- `npm ls @grpc/grpc-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grpc/grpc-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m9gg-hp2v-232j (GitHub-reviewed advisory GHSA-m9gg-hp2v-232j lists affected ranges: npm @grpc/grpc-js >=0 =1.14.0 <1.14.5)
- Verified: https://osv.dev/vulnerability/GHSA-m9gg-hp2v-232j (OSV record GHSA-m9gg-hp2v-232j lists affected ranges: npm @grpc/grpc-js >=0 =1.14.0 <1.14.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…