Skip to content

← Actionable
Low, CVSS 3.7amended

@grpc/grpc-js: The server transmits some error messages thrown by method handlers to the client in status messages

CVE-2026-101915GHSA-f596-whhp-79r4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grpc/grpc-js 1.14.5, 1.13.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @grpc/grpc-js

    Affected
    < 1.13.6>= 1.14.0, < 1.14.5
    Fixed in
    1.14.5, 1.13.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-101915: 0.25% estimated exploitation activity in the next 30 days; percentile 16.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If an application method handler crashes, the error message is included in the status message sent to the client. This can leak to the client any sensitive data that may be included in the error message. This impacts anyone using @grpc/grpc-js to run servers. Patches This vulnerability is fixed in 1.13.6 and 1.14.5. Workarounds This can be avoided by using a top-level error handler in method handlers to strip out sensitive error information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f596-whhp-79r4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-f596-whhp-79r4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f596-whhp-79r4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-101915

Advisory: @grpc/grpc-js: The server transmits some error messages thrown by method handlers to the client in status messages
IDs: CVE-2026-101915, GHSA-f596-whhp-79r4
Record: https://patchnext.com/advisories/cve-2026-101915 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grpc/grpc-js 1.14.5, 1.13.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grpc/grpc-js: affected < 1.13.6; >= 1.14.0, < 1.14.5; fixed in 1.14.5, 1.13.6

## Suggested inspection (read-only)
- `npm ls @grpc/grpc-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grpc/grpc-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f596-whhp-79r4 (GitHub-reviewed advisory GHSA-f596-whhp-79r4 lists affected ranges: npm @grpc/grpc-js >=0 =1.14.0 <1.14.5)
- Verified: https://osv.dev/vulnerability/GHSA-f596-whhp-79r4 (OSV record GHSA-f596-whhp-79r4 lists affected ranges: npm @grpc/grpc-js >=0 =1.14.0 <1.14.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…