Angular SSR: Denial of Service (DoS) via Infinite Loop on Malformed DOCTYPE
CVE-2026-101895GHSA-f67j-2jqw-jpq7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0, < 22.1.6>= 21.0.0, < 21.2.23>= 20.0.0, < 20.3.31<= 19.2.25
- Fixed in
- 21.2.23, 20.3.31, 22.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f67j-2jqw-jpq7 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f67j-2jqw-jpq7 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-101895: 0.87% estimated exploitation activity in the next 30 days; percentile 58.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Denial of Service (DoS) vulnerability exists in @angular/platform-server's DOM emulation parser (domino). When processing untrusted user input containing an incomplete DOCTYPE declaration ending with whitespace before EOF (such as <!DOCTYPE html ), the HTML parser enters an infinite synchronous loop, pegging CPU utilization at 100% and completely freezing the Node.js server process. Technical Description In Angular Server-Side Rendering (SSR), @angular/platform-server uses domino to parse and sanitize HTML bound through template bindings (such as [innerHTML]) or manipulated via DOM APIs. In Domino's HTML parser (lib/HTMLParser.js), tokenizer states that specify fixed lookahead—such as afterdoctypenamestate (lookahead = 6)—rely on the state handler function to explicitly advance the character index pointer (nextchar). While branches for whitespace, , and keyword matching advance nextchar, the EOF branch (case -1: // EOF) emitted doctype and EOF tokens without advancing nextchar or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-f67j-2jqw-jpq7
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-f67j-2jqw-jpq7
- Revision 1 · created ·
Published from ghsa record GHSA-f67j-2jqw-jpq7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-101895 Advisory: Angular SSR: Denial of Service (DoS) via Infinite Loop on Malformed DOCTYPE IDs: CVE-2026-101895, GHSA-f67j-2jqw-jpq7 Record: https://patchnext.com/advisories/cve-2026-101895 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/platform-server 22.1.6, 21.2.23, 20.3.31. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/platform-server: affected >= 22.0.0, < 22.1.6; >= 21.0.0, < 21.2.23; >= 20.0.0, < 20.3.31; <= 19.2.25; fixed in 21.2.23, 20.3.31, 22.1.6 ## Suggested inspection (read-only) - `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/platform-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f67j-2jqw-jpq7 (GitHub-reviewed advisory GHSA-f67j-2jqw-jpq7 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25) - Verified: https://osv.dev/vulnerability/GHSA-f67j-2jqw-jpq7 (OSV record GHSA-f67j-2jqw-jpq7 lists affected ranges: npm @angular/platform-server >=22.0.0 =21.0.0 =20.0.0 =0 <=19.2.25) Commands are suggestions: review each one before running it.
Loading voting…